0

Requirement to install collectd to monitor resources. Steps done do far:

    yum install epel-release # this failed as pubilc key is not installed

     yum install --nogpgcheck epel-release # failed with error 

Transaction check error:      

    file /etc/rpm/macros.ghc-srpm from install of epel-release-6-8.noarch conflicts with file from package redhat-rpm-config-9.1.0-72.el7.noarch

    yum install --nogpgcheck --skip-broken collectd # failed with error

Packages skipped because of dependency problems:
    collectd-4.10.9-4.el6.x86_64 from epel

Error: Package: collectd-4.10.9-4.el6.x86_64 (epel)
           Requires: libyajl.so.1()(64bit)
Error: Package: collectd-4.10.9-4.el6.x86_64 (epel)
           Requires: libpython2.6.so.1.0()(64bit)

The question: I have installed the epel repo Is there another repo I should be using because of the conflicts error?

4

unable to install collectd on Rhel 7

$ rpm -qa epel-release
epel-release-7-11.noarch

... So please install the right version of epel-release. You got the EL6 version, epel-release-6-8.noarch ... ( and the wrong collectd : collectd-4.10.9-4.el6.x86_64 ).

epel-release https://archive.fedoraproject.org/pub/epel/7/x86_64/Packages/e/epel-release-7-11.noarch.rpm

Download, and install : # cd Downloads/ && yum install ./epel-release-7-11.noarch.rpm

# yum install collectd : I got version 5.8.0-1.el7

  • Thank you. I found that indeed I has version 6 listed in the epel.repo file. Ones this was changed to 7 and then yum clean all, the new public key downloaded and I could then install collectd-5.8.0-1.el7 – Colinux Feb 19 '18 at 13:30
  • 1
    FYI you can just do yum install https://archive.fedoraproject.org/pub/epel/7/x86_64/Packages/e/epel-release-7-11.noarch.rpm – jordanm Feb 19 '18 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.