0

Some people had met some similar problems but nothing solves my problem; my log file

# tail -f /var/log/unattended-upgrades/unattended-upgrades.log 
2018-02-18 13:25:37,656 DEBUG No conffiles in deb 
'/var/cache/apt/archives/libgfortran3_4.9.2-10+deb8u1_amd64.deb' (There 
is no member named 'conffiles')
2018-02-18 13:25:37,657 DEBUG blacklist: []
2018-02-18 13:25:37,658 DEBUG whitelist: []
2018-02-18 13:25:37,658 DEBUG InstCount=23 DelCount=0 BrokenCount=0
2018-02-18 13:25:37,660 INFO Packages that will be upgraded: cpp-4.9 
g++-4.9 gcc-4.9 gcc-4.9-base gcc-4.9-base:i386 libasan1 libatomic1 
libcilkrts5 libgcc-4.9-dev libgcc1 libgcc1:i386 libgfortran3 libgomp1 
libitm1 liblsan0 libobjc-4.9-dev libobjc4 libquadmath0 libstdc++-4.9-dev 
libstdc++6 libstdc++6:i386 libtsan0 libubsan0
2018-02-18 13:25:37,662 INFO Writing dpkg log to '/var/log/unattended-
upgrades/unattended-upgrades-dpkg.log'
2018-02-18 13:27:02,483 INFO All upgrades installed
2018-02-18 13:27:02,485 DEBUG Extracting content from 
'/var/log/unattended-upgrades/unattended-upgrades-dpkg.log' since '2018-
02-18 13:25:37.661632'
2018-02-18 13:27:02,511 DEBUG Sending mail to 'xxxyyyy@gmail.com'
2018-02-18 13:27:02,713 DEBUG mail returned: 0


# cat /etc/apt/listchanges.conf 
[apt]
frontend=pager
email_address=xxxyyyy@gmail.com
confirm=0
save_seen=/var/lib/apt/listchanges.db
which=news

But the message doesn't go to my email address. Of course mailx makes the job:

$ echo "Just testing mailx" | mail -s "Yooo woot" xxxyyyy@gmail.com

and I receive my message... I'm using smtp configuration in my .mailrc file

So what can I do? thanks for your helps

1

Have you got a system-wide MTA configured for off-site mail delivery? Unattended-upgrades does not run in your name, so it won't read your ~/.mailrc. If you're running with Debian defaults, you probably have Exim installed (check with apt-cache policy exim4). Run dpkg-reconfigure exim4-config to configure remote delivery either via smarthost or by direct MX depending on your connection (basically, transfer the settings from your ~/.mailrc). This will also make your personal SMTP settings unnecessary. Check /var/log/exim4/mainlog* for clues if it still does not work.

  • At the moment I've finished to set exim4 up to send email correctly by test: echo "Subject: test" | /usr/sbin/exim4 -v user@my.domain I'm waiting for UU mail sending to confirm the correct answer. It'll be for an error or a real upgrading... – user3371854 Feb 20 '18 at 14:18
  • It seems not working. Just upgrading libfreexl1. U-U log file doesn't show any message about emailing report....where can I check? p.s. It seems I don't have any mainlog* file.... – user3371854 Mar 3 '18 at 11:02
  • Does systemctl status exim4 report active (running)? /var/log/exim4/mainlog really should exist unless you manually reconfigured Exim logging. On the other hand if unattended-upgrades does not log sending a mail, there's no use looking for one. – Ferenc Wágner Mar 4 '18 at 9:20
  • It was an errata configuration about Exim4!. My MTA transferred a root@mydomain insted of myaddressname@domain so the smtp server rejected my mail. This was crucial for my understanding. – user3371854 Mar 5 '18 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.