4

After the latest updates (I assume to gnome-shell), my touchpad right-click switched from "pressing bottom right zone" to "two-finger tap anywhere".

I find this confusing and I want to restore my right-clicks to pressing the bottom-right part of the touchpad.

What I tried so far:

Any ideas?

9

I came across https://askubuntu.com/questions/999631/ubuntu-17-10-disable-touchpad-bottom-right-corner-right-click

That pointed me in the right direction.

Running

gsettings list-recursively org.gnome.desktop.peripherals.touchpad

lists all touchpad settings. I'm only interested in

gsettings get org.gnome.desktop.peripherals.touchpad click-method

which at the moment returns fingers.

Now I just needed to know what are the valid options I can set this key to. After some digging, I found range

gsettings range org.gnome.desktop.peripherals.touchpad click-method

which returns

enum
'default'
'none'
'areas'
'fingers'

Finally, running this solved it:

gsettings set org.gnome.desktop.peripherals.touchpad click-method areas
| improve this answer | |
2

This can be done in the GUI as well, if you like (at least, it can as of Ubuntu 19.04). Use the Ubuntu Software app to install the "GNOME Tweaks" app. Then launch GNOME Tweaks and in the "Keyboard and Mouse" section, click your desired setting under "Mouse Click Emulation". In this case, the asker wants the "Area" option, but you can also choose "Fingers" if you prefer the two-finger right click.

The GNOME Tweaks app edits the same setting mentioned in the accepted answer, it just lets you do it without the command line if you're more comfortable using a GUI.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.