-4

I want to use the following command, which is for Ubuntu and Debian users:

chmod 600 MOK.priv

However, I am using Fedora 27 and it does not work for me there since I get Command not found.... Does anyone know the equivalent in Fedora 27?

EDIT:

I want to run this whole thing, but on Fedora:

$ sudo -i
# mkdir /root/module-signing
# cd /root/module-signing
# openssl req -new -x509 -newkey rsa:2048 -keyout MOK.priv -outform DER -out MOK.der -nodes -days 36500 -subj "/CN=YOUR_NAME/"
[...]
# chmod 600 MOK.priv

2nd EDIT:

The reason why I want to run the above is because I want to install VirtualBox 5.2 on Fedora 27 by using these instructions: https://www.if-not-true-then-false.com/2010/install-virtualbox-with-yum-on-fedora-centos-red-hat-rhel/# However, when I get to the command /usr/lib/virtualbox/vboxdrv.sh setup as shown below to rebuild the kernel modules after I have installed VirtualBox I get the following:

# /usr/lib/virtualbox/vboxdrv.sh setup   
vboxdrv.sh: Stopping VirtualBox services.   
vboxdrv.sh: Building VirtualBox kernel modules.    
vboxdrv.sh: Starting VirtualBox services.    
vboxdrv.sh: Building VirtualBox kernel modules.    
vboxdrv.sh: failed: modprobe vboxdrv failed. Please use 'dmesg' to find out why. 

So I get failed: modprobe vboxdrv failed. Please use 'dmesg' to find out why..
But I guess I have to make another thread about it.

  • Does it work when you call chmod with the full path /usr/bin/chmod 600 MOK.priv? – Thomas Feb 17 '18 at 13:18
7

The equivalent is the same command - chmod. chmod isn't a Debian / Ubuntu specific thing, it's a universal across all Linux / UNIX platforms. The path to chmod on Fedora is /usr/bin/chmod; if you don't have that directory (/usr/bin) in your path, you should. If you don't have the actual binary on your system, you have bigger problems as there is something seriously broken about your system.

  • /usr/bin and /usr/bin/chmod is on my system, so there should be no problems there. Actually I just wanted to run this whole thing: $ sudo -i # mkdir /root/module-signing # cd /root/module-signing # openssl req -new -x509 -newkey rsa:2048 -keyout MOK.priv -outform DER -out MOK.der -nodes -days 36500 -subj "/CN=YOUR_NAME/" [...] # chmod 600 MOK.priv – user164324 Feb 17 '18 at 13:07
1

There's a bug in Fedora 27 with chmod: read about it here. That what you're experiencing could be another bug.

  • I actually already disabled SELinux. – user164324 Feb 17 '18 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.