-4

This question is an exact duplicate of:

I'am using kali linux 2017.1 64 bit and I'am traying to install a certain package named lib32stdc++6 to solve the flutter compatibility issue. The problem is that apt-get install could not handle this one and I got the following output:

After this operation, 306 MB disk space will be freed.
Do you want to continue? [Y/n] Y
Err:1 http://http.kali.org/kali kali-rolling/main amd64 libc6-i386 amd64 2.26-2                                                            
  404  Not Found
Err:2 http://http.kali.org/kali kali-rolling/main amd64 lib32stdc++6 amd64 7.2.0-18
  404  Not Found
E: Failed to fetch http://http.kali.org/kali/pool/main/g/glibc/libc6-i386_2.26-2_amd64.deb  404  Not Found
E: Failed to fetch http://http.kali.org/kali/pool/main/g/gcc-7/lib32stdc++6_7.2.0-18_amd64.deb  404  Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

so I tried the --fix-missing flag and I got:

After this operation, 306 MB disk space will be freed.
Do you want to continue? [Y/n] y
Err:1 http://http.kali.org/kali kali-rolling/main amd64 libc6-i386 amd64 2.26-2                                                            
  404  Not Found
Err:2 http://http.kali.org/kali kali-rolling/main amd64 lib32stdc++6 amd64 7.2.0-18
  404  Not Found
Unable to correct missing packages.
E: Failed to fetch http://http.kali.org/kali/pool/main/g/glibc/libc6-i386_2.26-2_amd64.deb  404  Not Found
E: Failed to fetch http://http.kali.org/kali/pool/main/g/gcc-7/lib32stdc++6_7.2.0-18_amd64.deb  404  Not Found
E: Aborting install.

I searched in the internet and stack overflow in particular and did not find an effective answer. I found a post about installing a 32bit package on 64bit linux, it says that I should run the following commands:

dpkg --add-architecture i386
apt-get update
apt-get install lib32gcc1

Which gave me this very same output:

After this operation, 306 MB disk space will be freed.
Do you want to continue? [Y/n] Y
Err:1 http://http.kali.org/kali kali-rolling/main amd64 libc6-i386 amd64 2.26-2
  404  Not Found
Err:2 http://http.kali.org/kali kali-rolling/main amd64 lib32stdc++6 amd64 7.2.0-18
  404  Not Found
E: Failed to fetch http://http.kali.org/kali/pool/main/g/glibc/libc6-i386_2.26-2_amd64.deb  404  Not Found
E: Failed to fetch http://http.kali.org/kali/pool/main/g/gcc-7/lib32stdc++6_7.2.0-18_amd64.deb  404  Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I also checked this link https://packages.debian.org/stretch/amd64/lib32stdc++6/download and followed this instructions by add deb http://ftp.de.debian.org/debian stretch main at the and of the file /etc/apt/sources.list and run:

apt-get update
apt-get install lib32stdc

And got :

After this operation, 306 MB disk space will be freed.
Do you want to continue? [Y/n] Y
Err:1 http://http.kali.org/kali kali-rolling/main amd64 libc6-i386 amd64 2.26-2
  404  Not Found
Err:2 http://http.kali.org/kali kali-rolling/main amd64 lib32stdc++6 amd64 7.2.0-18
  404  Not Found
E: Failed to fetch http://http.kali.org/kali/pool/main/g/glibc/libc6-i386_2.26-2_amd64.deb  404  Not Found
E: Failed to fetch http://http.kali.org/kali/pool/main/g/gcc-7/lib32stdc++6_7.2.0-18_amd64.deb  404  Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

marked as duplicate by Rui F Ribeiro, cas, Satō Katsura, GAD3R, Anthony Geoghegan Feb 18 '18 at 16:34

This question was marked as an exact duplicate of an existing question.

  • This book is written to help first-time Linux users, as well as current Kali users seeking to deepen their knowledge about the underpinnings of Kali, as well as those who have used Kali for years but who are looking to formalize their learning, expand their use of Kali, and fill in gaps in their knowledge. - johnny long kali.training/downloads/Kali-Linux-Revealed-1st-edition.pdf – Tim_Stewart Mar 22 '18 at 20:57
1

This is because Kali Linux is only for penetration purposes, not general use. See Why is Kali Linux so hard to set up? Why won't people help me?. Kali's apt is not supported by Kali's developers, which is why you encounter such errors. Please switch to another distribution which is suitable for general use (like Debian, Ubuntu, Fedora, Trisquel). Personally, I recommend Trisquel for newbies (Ubuntu if you don't want to encounter hardware issues).

Not the answer you're looking for? Browse other questions tagged or ask your own question.