1

less works very strange, discard several top lines, does not update correctly after moving up/down or left/right. Also -S does not work. If I move far right, less starts to work correctly, but keep failing if move back left.

Here is an example: each line starts with Line N and then English alphabet multiple times. In the beginning I run most to show the content of the file.

less

The same happened in different terminal emulators. But without X running less worked fine. I use Manjaro Linux and bspwm.

What can be the problem and how to solve it?

closed as unclear what you're asking by G-Man, Timothy Martin, Archemar, Satō Katsura, Rui F Ribeiro Feb 17 '18 at 17:09

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    it looks like less expects your terminal to be a different width than it really is. – Jasen Feb 17 '18 at 3:37
  • @Jasen Thank you, maybe it's the problem? Do you know what can be the reason for that? – Timofey Prodanov Feb 17 '18 at 21:07
-1

Have you tried using this command with other long text files? The man page for less says

Also, less does not have to read the entire input file before starting, so with large input files it starts up faster than text editors like vi (1).

Perhaps the program is intentionally skipping over the first lines in the file, to save on memory? The purpose of this program is to start from the bottom, so it would make sense if it simply didn't load the content at the very beginning.

  • Probably not, I tried with different files, this file is something like 200 lines with length 150. Could it be that less has access only to extremely small memory? – Timofey Prodanov Feb 17 '18 at 10:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.