1

I'm trying install the Discord app on Opensuse 42.3.

I downloaded the tar.gz and extracted its contents. I then make the discord.desktop file executable by running the command sudo chmod +x ./Discord/discord.desktop.

Then I double click the discord.desktop file, but it doesn't run successfully. Below is a screenshot of the window after opening:

Discord screenshot

I tried to start Discord from the command line and I received the following error:

:~> sudo chmod +x Downloads/Discord/discord.desktop 
[sudo] password for root: 
:~> ./Downloads/Discord/discord.desktop 
./Downloads/Discord/discord.desktop: line 1: [Desktop: command not found
./Downloads/Discord/discord.desktop: line 4: unexpected EOF while looking for matching `''
./Downloads/Discord/discord.desktop: line 10: syntax error: unexpected end of file

Contents of discord.desktop is -

rajkumar@linux-7owj:~> cat Downloads/Discord/discord.desktop

[Desktop Entry]
Name=Discord
StartupWMClass=discord
Comment=All-in-one voice and text chat for gamers that's free, secure, and works on both your desktop and phone.
GenericName=Internet Messenger
Exec=/usr/share/discord/Discord
Icon=discord
Type=Application
Categories=Network;InstantMessaging;

X-Session Errors doesn't give any useful result. I tried it before and after executing the discord

rajkumar@linux-7owj:~> tail -f ~/.xsession-errors
tail: cannot open '/home/rajkumar/.xsession-errors' for reading: No such file or directory
tail: no files remaining

Below is my OS details:

:~> lsb_release 
LSB Version:    core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64:desktop-4.0-amd64:desktop-4.0-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.2-amd64:graphics-3.2-noarch:graphics-4.0-amd64:graphics-4.0-noarch

When lauching discord on Opensuse by installing it with snap there is the following errors:

Gtk-Message: Failed to load module "canberra-gtk-module"
Discord 0.0.4
Starting updater.
[Modules] Modules initializing
[Modules] Distribution: remote
[Modules] Host updates: enabled
[Modules] Module updates: enabled
[Modules] Module install path: /home/tjiho/snap/discord/52/.config/discord/0.0.4/modules
[Modules] Module installed file path: /home/tjiho/snap/discord/52/.config/discord/0.0.4/modules/installed.json
[Modules] Module download path: /home/tjiho/snap/discord/52/.config/discord/0.0.4/modules/pending
[11045:0219/154734.826940:FATAL:platform_font_linux.cc(63)] Check failed: typeface. Could not find any font: Noto Sans, sans
#0 0x000001e57c8e <unknown>
#1 0x000001e6a80b <unknown>
#2 0x00000198780d <unknown>
#3 0x00000198744f <unknown>
#4 0x000001988106 <unknown>
#5 0x000001972469 <unknown>
#6 0x000000b3271e <unknown>
#7 0x000000d87a03 <unknown>
#8 0x000003c22106 atom::api::WebContents::InitWithSessionAndOptions()
#9 0x000003c2298f atom::api::WebContents::WebContents()
#10 0x000003c2d886 atom::api::WebContents::Create()
#11 0x000003c3fb35 atom::api::Window::Window()                                                                                                                                                 
#12 0x000003c4164c atom::api::Window::New()                                                                                                                                                    
#13 0x000003be75f0 mate::internal::InvokeNew<>()                                                                                                                                               
#14 0x000003be7780 mate::internal::Dispatcher<>::DispatchToCallback()                                                                                                                          
#15 0x7f388e3e6e6f <unknown>                                                                                                                                                                   
#16 0x7f388e7f637b <unknown>                                                                                                                                                                   
#17 0x7f388e7f5e39 <unknown>                                                                                                                                                                   
#18 0x0c816f2843a7 <unknown>                                                                                                                                                                   

Aborted (core dumped)

What can I do to fix this issue?

  • Can you post the contents of the desktop file? Line 1 of the error looks like there is some bad syntax in there. – Mountainerd Feb 16 '18 at 23:40
  • 1
    Please don't post images of text. Copy and paste the text itself into your question and format it as code by selecting it and pressing Ctrl-K or by using the editor's {} icon. Also, don't post images that add nothing of value to the question - if you say that double-clicking the icon does nothing we'll accept that without needing to see an empty terminal window as proof. we will, however want to see the .desktop file AND some relevant lines from tail -f ~/.xsession-errors while clicking it. – cas Feb 16 '18 at 23:56
  • Joshua - I've updated the question with the discord.desktop file contents. – Rajkumar Natarajan Feb 17 '18 at 17:49
1

you can install it using flatpack:

$ sudo zypper install flatpak
$ sudo flatpak remote-add --if-not-exists flathub https://dl.flathub.org/repo/flathub.flatpakrepo
$ sudo flatpak install --from https://flathub.org/repo/appstream/com.discordapp.Discord.flatpakref

then logout and login and you will have dicord installed

  • Your suggestion worked magically!!! Accepted your solution. – Rajkumar Natarajan Feb 19 '18 at 20:55
1

For others who may not want to work with flatpak, you are likely just missing libc++1 package. I experienced same issue on Ubuntu.

Same named package, libc++1 exists for OpenSuse

  • Completely exit Discord (quit from system tray).
  • Install libc++1:

    sudo zypper install

And here was my answer I provided on Ask Ubuntu:

Same issue on XUbuntu 16.04 using the gzip package (Discord 0.0.4). Installed "libc++1" package and Discord launched successfully--no more empty window:

sudo aptitude install libc++1

Note: I found forum posts which indicated "libc++" was required and to install clang toolchain package which should include libc++. This did not work so I suspect newer version of Discord requires newer libc++ provided by libc++1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.