2

For Linux Mint 18.3, 32-bit, MATE desktop 1.18.0.

In BASH, typing calendar produces the following error.

rbv@rbv-F80Q ~ $ calendar
In file included from /usr/share/calendar/calendar.all:23:0,
                 from <stdin>:16:
/usr/share/calendar/calendar.croatian:10:0: fatal error: hr_HR/calendar.all: No such file or directory
 #include <hr_HR/calendar.all>
 ^
compilation terminated.
Feb 15  Galileo Galilei born in Pisa, Italy, 1564

------ list of dates ------ 

Feb 16  Stephen Decatur burns US frigate in Tripoli, 1804
rbv@rbv-F80Q ~ $

I've located the cited file calendar.croatian and offending line:

/*
 * Croatian calendar files
 *
 * $FreeBSD$
 */

#ifndef _calendar_croatian_
#define _calendar_croatian_
/* THIS IS THE LINE CITED IN THE ERROR */
#include <hr_HR/calendar.all>

#endif /* !_calendar_croatian_ */

But I have no idea what to do. Delete the line? Edit it? Or?

Or is the best solution to edit calendar.all and simply delete the line #include <calendar.croatian>? Although I'd like to actually fix the problem if possible rather than simply deleting things...


EDIT #1: Unable to reinstall bsdmainutils

Tried the suggestion to reinstall basmainutils but it seems not to exist on my system AND I'm unable to use apt-get to download and install it.

rbv@rbv-F80Q ~ $ sudo apt-get install --reinstall bsdmainutils
[sudo] password for rbv: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reinstallation of bsdmainutils is not possible, it cannot be downloaded.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
rbv@rbv-F80Q ~ $ 

With specific regard to reinstall, it does not seem to already exist on this 32-bit Linux Mint / MATE computer.


EDIT #2: Attempt to use dpkg-query to identify owner of basmainutils

In response to commentor suggestion, ran the following:

rbv@rbv-F80Q ~ $ dpkg-query -S /usr/share/calendar/calendar.all
bsdmainutils: /usr/share/calendar/calendar.all

This seemingly indicates that although I can't use about or which or apropos or man to find anything about bsdmainutils, it's evidently the owner of calendar.all.

Note also that the locate bsdmainutils command produced the following:

rbv@rbv-F80Q ~ $ locate bsdmainutils
/etc/cron.daily/bsdmainutils
/etc/default/bsdmainutils
/usr/share/doc/bsdmainutils
/usr/share/doc/bsdmainutils/README
/usr/share/doc/bsdmainutils/calendarJudaic.py.gz
/usr/share/doc/bsdmainutils/changelog.gz
/usr/share/doc/bsdmainutils/copyright
/usr/share/doc/bsdmainutils/source.data.gz
/usr/share/lintian/overrides/bsdmainutils
/var/lib/dpkg/info/bsdmainutils.conffiles
/var/lib/dpkg/info/bsdmainutils.list
/var/lib/dpkg/info/bsdmainutils.md5sums
/var/lib/dpkg/info/bsdmainutils.postinst
/var/lib/dpkg/info/bsdmainutils.prerm
rbv@rbv-F80Q ~ $ 

So on the one hand bsdmainutils seems to not be available to apt-get and so on, yet there are some basmainutils files present on the system.


EDIT #3: Circumvention found, see my answer to my own question, below

Although apt-get was unable to to locate and so reinstall bsdmainutils, the Synaptic package manager did list and so could reinstall it. Details below.

  • 1
    Did something happen recently with the bsdmainutils package? Perhaps reinstall that? – Jeff Schaller Feb 15 '18 at 18:39
  • Interesting; I must have found old information. Can you run dpkg-query -S /usr/share/calendar/calendar.all to see what package owns that file? – Jeff Schaller Feb 16 '18 at 20:23
  • See edit #2. Ran the command which indicated bsdmainutils was owner of calendar.all. But otherwise bsdmainutils is "invisible" to the commands I normally use to get information about a program or file. At the same time "locate" found several bsdmainutils files. Confusing... – RBV Feb 17 '18 at 21:29
  • Interesting; glad you got to the bottom of it; instead of editing the title, simply accept your own answer. That's how Stack Exchange indicates that a problem is solved. Thanks! – Jeff Schaller Feb 18 '18 at 0:07
1

I don't have a Linux Mint system to try this on, so I'm basing it on several - other - pages who demonstrated the --reinstall option:

apt-get install --reinstall bsdmainutils

The assumption here is that something inadvertently removed the /usr/share/calendar/hr_HR/calendar.all file. We're asking the package manager to reinstall the package, which should replace that file.

  • Per my edit to my original question, bsdmainutils seems not to exist on my computer AND apt-get can't download it... – RBV Feb 16 '18 at 20:08
0

Well, I "fixed" the problem -- but I'm not happy with the way it ended up being fixed.

The solution was to use Synaptic rather than apt-get on the command line to reinstall bsdmainutils. After doing that the error with calendar no longer occurred.

But this reflects another recurring problem I'm having ala Synaptic won't list programs that apt-get will install...?

In this instance the opposite of that existing post's issue occurred: Synaptic "knew about" a package that apt-get on the CLI did not. Point being that I can't figure out why apt-get often finds programs that Synaptic doesn't list. And in this instance, the opposite...


Edit #1: Problem may occur because Bleachbit deletes calendar files

IF you reinstall bsdmainutils and calendar again works properly, AND later the same problem recurs, THEN note that depending on settings, Bleachbit may be deleting files contained in /usr/share/calendar/. Use Edit -> Preferences -> Whitelist -> Add folder -> to exclude the files contained in /usr/share/calendar from deletion. NOTE that you may need to perform this operation for both Bleachbit as root and Bleachbit in user-account modes...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.