0

I'm using libreoffice as a pdf converter inside a docker container by utilising the headless functionality. How can I disable macros? I'm using debian strech-9.3 and libreoffice 5.4.5

0

1 Answer 1

0
+100

Are you familiar manipulating .idl files in the LibreOffice source code? According to the documentation you could compile LibreOffice from source and use the value specified here to prevent macros. If not you can edit the user profile to prevent macro execution. Here is a link.

If those methods do not work you will need to use a different tool to convert files such as pandoc.

To utilize pandoc you will need to follow this post's instructions.

2
  • Thank you for your great answer. One question... if I delete the contents of the basic folder in the profile, that means that I effectively disable the macros correct? Feb 26, 2018 at 10:58
  • As far as I can tell from the documentation that is one way to disable them. Most people use the menus in the graphical interface but by deleting the folders there shouldn't be a way for macro to run.
    – kemotep
    Feb 26, 2018 at 11:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .