1

I am having issues while trying to enable eth0 interface on my Pine64 SBC.

I am running the following Armbian version:

Title:          Armbian 5.38.180128 Pine64 Debian stretch next
Kernel:         Linux 4.14.15
Build date:     28.01.2018

I am able to connect a USB 2.0 to Ethernet adapter without any issues. The problem arises when I try to enable eth0 which is the Native Ethernet port.

pine64:/# ifconfig eth0 up
SIOCSIFFLAGS: No such device

pine64:/# dmesg | grep eth0
xxxxxx.ethernet eth0: Could not attach to PHY

The file var/log/messages shows the following:

device (eth0): driver '(null)' does not support carrier detection
device (eth0): driver 'unknown' does not support carrier detection

It definitely looks like a driver issue but reinstalling the following did not help:

firmware-linux-nonfree
firmware-linux

Setting network manager to ignore the carrier and restarting network services yielded no results:

$ cat /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile
ignore_carrier=eth0

Thoughts?

Thanks!

  • 2
    Are you sure your network interface has the name eth0? Debian has moved to "predictable network interface names", and away from names like eth0. Try running the command ip link to see a listing of the interfaces. – Johan Myréen Feb 14 '18 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.