1

Yesterday I updated my system (DELL laptop with Arch linux), and unfortunately today I realized that HDMI port cannot recognize the external monitor.

Until now I use the following command inside .xinitrc file but from today it stopped working.

xrandr | grep -q HDMI1 && xrandr --output eDP1 --auto --output HDMI1 --auto --right-of eDP1

Here is the Xorg log

lspci|grep VGA returns :

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

and xrandr returns :

Screen 0: minimum 8 x 8, current 1366 x 768, maximum 32767 x 32767
eDP1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 290mm x 160mm
   1366x768      60.00*+  40.00  
   1280x720      59.74  
   1024x768      60.00  
   1024x576      60.00    59.90    59.82  
   960x540       60.00    59.63    59.82  
   800x600       60.32    56.25  
   864x486       60.00    59.92    59.57  
   640x480       59.94  
   720x405       59.51    60.00    58.99  
   680x384       60.00  
   640x360       59.84    59.32    60.00  
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Any idea on what is going on? It seems that it recognizes the HDMI port but cannot send out any signal.

Thank you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.