0

I recently installed Linux Mint with following information:

DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=18.3
DISTRIB_CODENAME=sylvia
DISTRIB_DESCRIPTION="Linux Mint 18.3 Sylvia"
NAME="Linux Mint"

And I noticed that it can't open some particular websites (it stuck at waiting for www.domainname.etc ....). Then I tested with ping and I noticed that it can easily ping to those websites. I tested the Open DNS and tweaking the DNS settings but it didn't work. Does anyone know what can cause such problem? I also checked many links but none of them were useful.

Regarding the firewall problems here is the content of iptable:

sudo iptables -L -n

Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
  • 1
    Are you sure you don't have some kind of firewall which disables access to those sites for you? Why do you think it's a fault on DNS side? – rush Feb 12 '18 at 15:45
  • If you can ping the website with the domain name, your DNS is working fine. – Hunter.S.Thompson Feb 12 '18 at 15:47
  • I'm not sure about the firewall but I don't think that's the problem because I just installed the OS why it should have a firewall? DNS is the only thing that I can think of at the moment. – Kasrâmvd Feb 12 '18 at 15:47
  • @Hunter.S.Thompson Yes, you're right. – Kasrâmvd Feb 12 '18 at 15:48
  • @rush You can check the update. I added the content of iptable. – Kasrâmvd Feb 12 '18 at 15:57
0

I had that problem once under windows with a MTU not matching my environment. Try

ifconfig eth0 mtu 1400 up
  • I'm not connecting to eth0 but the wifi. And what is 1400? here? and what does this command do? – Kasrâmvd Feb 12 '18 at 16:53
  • Then use your wlan0 interface instead of eth0. On ethernet connections, there is usually a mtu (maximum transfer unit) of 1500 bytes. Depending on your internet connection some bytes are used for some overhead and you cannot put full 1500 bytes in. With 1400 you limit your mtu to 1400 bytes. Just give it a try, it is not persistent, a reboot will drop that setting. – Stephan Bahr Feb 12 '18 at 16:59
  • Unfortunately it didn't work. – Kasrâmvd Feb 12 '18 at 17:16
0

The problem lies with the firewall interface. Turn the firewall off and the problem goes away. I suspect application gateway settings are the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.