I have set up an Arch Linux system which had XFCE4 as a DE installed. While setting it up the way I like, I needed to reboot the machine. After that, my network interface was not found, I could not start Xorg ("Screens not found", but that's another problem...) and lightdm was broken (also another problem)

If I type "ip a" now, I only get the entry of "lo", while the interface which I used before was named "enp58s0f1".

I used both a repeater (which is connected to the router) and the ethernet connection directly, but both of them result in the same output...

I am pretty sure that it can't really be a driver/hardware error, for it already worked for a long time and i have several other distributions installed on the same machine on which there aren't any connection problems.

The problem already occured to other people, but none of the hints and solutions there worked for me.

Photo of some relevant commands and their output

Thanks for potential help, Alexander Schoch


The following are photos of lspci -vv. I am really sorry to have made photos, but i cannot save the output to a file and i am not using a virtualbox...

Photos of lspci -vv


pacman -Q linux && uname -r results in linux 4.15.1-2 and 4.14.15-1-ARCH, respecitvely. I see that there is a mismatch...


mkinitcpio -k 4.15.1-2-ARCH resulted in a positive result: It started a "dry run" (whatever that means)

  • What does ip link show?
    – Torin
    Feb 10, 2018 at 17:28
  • @TorinCarey exactly the same as ip a, only "lo" with some information behind it Feb 10, 2018 at 17:29
  • 1
    Edit your question with the output of pacman -Q linux && uname -r
    – jasonwryan
    Feb 10, 2018 at 18:41
  • 1
    Yes, take a live-cd of arch, then chroot and run proper mkinitcpio. Or the simplest way is to pacman -Sy linux, but your mkinitcpio.conf should be OK Feb 10, 2018 at 19:12
  • 2
    @GillesQuenot and jasonwryan Thank you guys so much! I have just reinstalled the kernel and it works fine now. You even solved my Xorg problems. Feb 10, 2018 at 20:51

2 Answers 2


After examinating your lspci -vv output, I see that the module section is missing.

After some search on the web ,I discover wich module you miss, so try this :

modprobe r8169

if there's an error, please tell us


To understand what's going on under the hood :

# strace -f -e trace=file modprobe r8169

Check if there's some wrong paths.


Update your system and reinstall your kernel in a chroot with :

pacman -Syu

(current linux kernel is 4.15, not 4.14)

  • okay. i tried that one and got "modprobe: FATAL: Module r8169 not found in directory /lib/modules/4.14.15-1-ARCH". I also tried the module rtsx_pci (the only one mentioned in "lspci -v") which resulted in the same output Feb 10, 2018 at 18:09
  • The latest kernel is 4.15 in arch. I have it there : /usr/lib/modules/4.15.1-2-ARCH/kernel/drivers/net/ethernet/realtek/r8169.ko.xz Feb 10, 2018 at 18:18
  • What is the output of find /usr/lib -name '*r8169*' ? Feb 10, 2018 at 18:19
  • in this directory, I got 8139cp.ko.xz, 8139too.ko.xz, atp.ko.xzand r8169.ko.xz. Using modprobe thoseNames, I get "Module theName not found in theDir" Feb 10, 2018 at 18:23
  • 1
    -Syu linux: partial updates are not supported (and likely what got OP into this mess in the first place).
    – jasonwryan
    Feb 10, 2018 at 22:09

For all those who have the same problem:

Boot into an external system (like an arch linux live stick), chroot into the arch partition and re-download the linux package via pacman (remember to establish your internet connection before using the chroot command). This did the trick for me.

Best, Alexander Schoch

  • ??? What's the point ? That's exactly whats we said... Feb 12, 2018 at 1:13
  • I know. But noone reads comments in stackexchange. That way, your solution is read at first sight. Feb 12, 2018 at 6:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .