3

Trying to install VMware Tools in 32 bits CentOS 6.9.

I do:

yum install open-vm-tools

Got output:

No package open-vm-tools available.

How to install VMware Tools for CentOS 6.9 ?

UPD

I did :

yum --enablerepo=extras install epel-release
yum install open-vm-tools

No errors during install procedure.

But VMware tools still not working. No copy/paste function, no file copy to/from host.

Mashine restart not helped.

Tried to restart service :

/etc/vmware-tools/services.sh restart 

But found that there is no such directory /etc/vmware-tools/. Where are vmware-tools located?

How to make vmware-tools work?

2

To install vmware tools on Centos 6.X:

  1. Add the VM Tools for RHEL repository

File - /etc/yum.repos.d/vmware.repo

[vmware-tools]
name=VMware Tools for Red Hat Enterprise Linux $releasever – $basearch
baseurl=http://packages.vmware.com/tools/esx/latest/rhel6/$basearch
enabled=1
gpgcheck=1
gpgkey=http://packages.vmware.com/tools/keys/VMWARE-PACKAGING-GPG-RSA-KEY.pub
  1. Install vmware tools

yum install vmware-tools-esx-nox

To install open-vm-tools, do:

  1. Enable EPEL repo

yum --enablerepo=extras install epel-release

  1. Install open-vm-tools

yum install open-vm-tools

Sources:

Installing VMware tools on Centos 6 via yum

Install open-vm-tools on CentOS 6.x

  • I have installed vmtools, but they don't work. More details in UPD question body. – vico Feb 11 '18 at 10:02
  • 1
    To start them you need to type /etc/init.d/vmware-tools start. But please consider @RuiFRibeiro's advise on using open-vm-tools, as clearly they are the better choice. After you install open-vm-tools you just need to reboot your machine to make them work. – 13dimitar Feb 11 '18 at 10:25
7

For installing the open source VMware Tools for CentOS, you need first to install the EPEL repository with:

yum --enablerepo=extras install epel-release

Then to install the actual open source VMware Tools, it is indeed:

yum install open-vm-tools

This time, it won't give you any error.

Additionally, if installing VMWare Tools (open or not), take care to make sure you will be using the VMXNET NIC adapter interfaces and disk access paravirtualization.

Whilst normally the VMXNET adapter use/configuration can nowadays be pretty automatic, you need to do extra parametrisation on the ESXi/ESX side to take profit of disk controller paravirtualization (e.g. selecting a paravirtualized disk controller).

See VMWare KB: Configuring disks to use VMware Paravirtual SCSI (PVSCSI) adapters (1010398)

Additional notes:

The open-vm-tools is nowadays the recommended way to install VMware Tools add-ons due to the complexity that VMWare own official VMware Tools bring.

The official VMware Tools add-ons need to be compiled and installed as modules. Additional development tools, namely gcc and headers, the kernel headers source, and dkms need to be installed, adding size and complexity to the server, especially in a VM environment. As an additional complication, the official modules have to be (re)compiled each time the kernel is upgraded to a new version; consequently you also need to upgrade every time the kernel headers source, and the added inconvenience and delay of deploying and compiling things is not welcome to people doing system administration of multiple servers.

Whilst the open source VMWare Tools also had to be (re)compiled in the past, nowadays it just need to be installed.

As such, it is nowadays also much more lightweight and conducing to the UNIX philosophy of installing the minimum software needed in a server to install the open-vm-tools.

Over time, the support for VMWare is also getting incorporated into the Linux kernel (source), and open-vm-tools is gradually ending up not being much more than wrappers/scripts to interface with the kernel modules. see When do/did I need development tools/kernel source for `open-vm-tools`?

Furthermore, even the VMWare KBs and white papers recommend nowadays installing the open source VMware Tools, and leaving the official own VMWare Tools one for obsolete versions not supported by the open source version.

  • I have installed vmtools, but they don't work. More details in UPD question body. – vico Feb 11 '18 at 10:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.