0

I wanted to give a try to Linux again. So I decided to install Debian next to my Win 10. I prepared harddrives in Win 10:

Disc 1 (SSD 850 EVO [u]250[/u]GB):

One partition - Win 10

Disc 2 (SSD 850 EVO [u]500[/u]GB):

Two partitions with some data

Third partition for debian install

Fourth partition for swap

After some trouble with my flashdisk I finally get to installation. Debian is now installed on 3. partitions, but during the installation, GRUB bootloader failed:

Executing 'grub-install dummy' failed

So I skip this step and after finishing install I reboot my PC. After reboot, Win 10 loaded correctly. After next reboot I hit F11 for Boot device selection. Now I have here next to Win 10 also Debian: boot selection

But when I selected debian, I will boot into this: after boot Now I guess I should have register debian partition into GRUB. But I don't know how, can you give me some advice? Thanks a lot

closed as off-topic by Jeff Schaller, Satō Katsura, Archemar, Thomas Nyman, sebasth Feb 22 '18 at 22:16

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Satō Katsura, Archemar, Thomas Nyman, sebasth
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Have you tried unix.stackexchange.com/questions/423163/… ? Please replace hard disk number, kernal, initrd and grub.cfg properly. – Abhik Bose Feb 10 '18 at 13:10
  • An easy automated way (suggested for beginners) is to use bootrepairdisk (sourceforge.net/projects/boot-repair-cd)... You have just to burn it in a cd or a usb and boot from this... It will ask you if you want to apply a recommended repair and it will do what needed to repair your boot options and entries... – koleygr Feb 10 '18 at 14:38
  • @AbhikBose Thanks for advice. Now I can boot into Debian with commands in the linked question. But after i wrote them into grub.cfg (i have to created it), it will show me the GRUB OS selection window, but after i choose debian, it will give me erorr about initrd not found, you need to load kernel first – Sk1X1 Feb 10 '18 at 18:44
  • @Sk1X1 I believe it's due to some configuration error. Please use grub2-mkconfig tool to generate grub.cfg. – Abhik Bose Feb 10 '18 at 19:50
1

At the end, it was configruration error. I run update-grub and that created confiuration file grub-conf with right configuration.

Not the answer you're looking for? Browse other questions tagged or ask your own question.