1

These were Chrome's error messages on the command line:

ATTENTION: default value of option force_s3tc_enable overridden by environment.

[11850:11915:0210/111421.109731:ERROR:bus.cc(394)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")

[11850:11875:0210/111421.366506:ERROR:cert_verify_proc_nss.cc(922)] CERT_PKIXVerifyCert for translate.googleapis.com failed err=-5992

[11850:11878:0210/111421.366506:ERROR:cert_verify_proc_nss.cc(922)] CERT_PKIXVerifyCert for clientservices.googleapis.com failed err=-5992

...

This turned out to be the resolution in my case:

For some stupid reason, I had set my LD_LIBRARY_PATH environment variable to include /usr/local/firefox where my most recent Firefox version resides. There, Chrome finds libnss* libraries which differ from those in /usr/lib64. Removing /usr/local/firefox from LD_LIBRARY_PATH, e.g.

    setenv LD_LIBRARY_PATH

so that it is just empty, solves the problem for Chrome. (Firefox is working with or without the fix.)

I thought I'ld post this here even after it's been resolved.

  • 2
    You you have a fix, please create an answer. – John Feb 10 '18 at 11:06
  • It is perfectly ok to answer one's own questions, but you should do that in a proper answer, not in the question itself. – Kusalananda Feb 10 '18 at 12:26
  • 1
    @John: Thanks for telling me how to handle this! – user3238459 Feb 11 '18 at 11:23
  • @Kusalananda: Thanks for your help! – user3238459 Feb 11 '18 at 11:24
1

The problem was caused by Google Chrome using a version of libnss3.so in
/usr/local/firefox which came with Firefox 58.0.1. /usr/local/firefox/libnss3.so differs from /usr/lib64/libnss3.so which seems to be the one that Google Chrome relies on. The problem arose after adding /usr/local/firefox to the LD_LIBRARY_PATH environment variable in order to get an installation of Firefox 58.0.1 in /usr/local running. Removing /usr/local/firefox from LD_LIBRARY_PATH has solved the problem with Google Chrome.

It was kind of treacherous that both browsers, Google Chrome (version 64.0.3282.140 (64-bit)) and Firefox 58.0.1 (installed in /usr/local/firefox), were nicely running side by side for a few days until a reboot made the change in LD_LIBRARY_PATH effective for Google Chrome.

0

Just got the same problem while starting chrome as child process from java program directly under eclipse IDE.

Eclipse has curiously extended the environment with LD_LIBRARY_PATH=/usr/lib/firefox

Adding an additional environment setting LD_LIBRARY_PATH=/nonexisting_dir to launch configuration solved the problem.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.