1

I am on Debian 9 and want to set up a static ip address. Following this guide I should find a line beginning with auto eth0 in /etc/network/interfaces, but there is no such thing here. Are these things changed in Debian 9? From ip a my network interface is wlo1 - or this is just a loopback device?

root@emerald:~# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback
root@emerald:~# ls /etc/network/interfaces.d/
root@emerald:~#

Output of ip a:

root@emerald:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eno1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether ec:9a:74:f3:72:a9 brd ff:ff:ff:ff:ff:ff
3: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 74:de:2b:9f:23:90 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.100/24 brd 192.168.1.255 scope global dynamic wlo1
       valid_lft 86377sec preferred_lft 86377sec
    inet6 fe80::76de:2bff:fe9f:2390/64 scope link 
       valid_lft forever preferred_lft forever
  • wlo1 is your wifi interface , please add the output of ip a. – GAD3R Feb 10 '18 at 10:08
  • Added ip a output. – robert Feb 10 '18 at 11:23
3

Since 2009 a Consistent Network Device Naming convention was adopted for naming Ethernet adapters in Linux, that's why you have eno1 and not eth0. And for lacking a configuration for your main NIC in /etc/networks/interfaces - this is most likely because you have network-manager installed. You can see some information about it here.

If you want to use /etc/network/intefaces, simply disable or remove Network-Manager and configure eno1 by your requirements in /etc/network/interfaces.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.