1

I'm reposting Gnome Session Doesn't Start on Remote X Server, here, because I believe it's a Gnome question, not just an Ubuntu one.

I have an Ubuntu host, which I reach via ssh -Y. The client is my macOS laptop, running XQuartz. I can do xclock or other X apps from the host and see them on my laptop. What I cannot run is gnome-session, which, as far as I understand, should be the whole thing that comes up when I login to the machine from the local console. DISPLAY is correctly set, but seems to be ignored.

Passing --display="$DISPLAY" to gnome-session yields:

** (gnome-session-binary:5943): WARNING **: Unknown option --display=localhost:10.0

Indeed, my manpage for gnome-session doesn't mention --display, while manpages around Internet do. So, I guess, it was removed at some point, do I still have a way to do it?

I've also discovered that other gnome applications (e.g., gnome-software) have a --display option, but they ignore it and the application runs on the console desktop, rather than on my laptop.

0

I've also discovered that other gnome applications (e.g., gnome-software) have a --display option, but they ignore it and the application runs on the console desktop, rather than on my laptop.

I assume you are running Gnome 3 on the server, too, not only per SSH? I assume it runs as a wayland session. The Gnome apps may use WAYLAND_DISPLAY instead of DISPLAY. Check XDG_SESSION_TYPE. If it is set to wayland, Gnome apps will use the wayland display instead of your SSH display. Try to run them with XDG_SESSION_TYPE=x11.

Indeed, my manpage for gnome-session doesn't mention --display, while manpages around Internet do. So, I guess, it was removed at some point, do I still have a way to do it?

gnome-session should regard DISPLAY, you don't need --display. However, gnome-shell has option --display.

What I cannot run is gnome-session

I found that gnome-session and libmutter often have segfaults if not running with native display hardware. Check dmesg on your server.

Maybe you can run env XDG_SESSION_TYPE=x11 gnome-session, but I suspect it will segfault, too. Also, you can try gnome-shell instead of gnome-session.

I recommend to use another and more lightweight desktop environment for SSH, for example lxde (lxsession) or xfce (startxfce4), or just a window manager like openbox (openbox --sm-disable).

  • Thanks, tried XDG_SESSION_TYPE and WAYLAND_DISPLAY, nothing work. I think I'll give up, at least with gnome. – zakmck Feb 11 '18 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.