0

Well I'm trying to install URI::_foreign on my server (I have root access) I get the following errors:

CPAN: Storable loaded ok (v2.20)
Going to read '/root/.cpan/Metadata'
Database was generated on Wed, 07 Feb 2018 18:54:45 GMT
Warning: Cannot install URI::_foreign, don't know what it is.
Try the command

i /URI::_foreign/

to find objects with matching identifiers.

How I can resolve this? I've tried on 3 different CentOS systems, all the same.

2

URI::_foreign is not a distribution or module by itself. It is one of the included modules of the Perl URI distribution, so just use your favorite CPAN tool to install the URI Perl distribution.

But you can also succeed by just installing the CentOS perl-URI package, no need to go to CPAN (except if you need a specific version different from the Linux distribution package).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.