1

During boot, my CentOS 7 box yields a bunch of messages like [ 202.161851] myhost dracut-initqueue[381]: Warning: dracut-initqueue timeout - starting timeout scripts and then drops me to a prompt. I wait a few minutes for my storage to finish loading and then type exit and the boot completes.

How do I change the timeout so instead of giving me a prompt after a couple minutes it actually waits for the storage to load and boots automatically? I initiate most reboots remotely and it is really annoying to have to jump on the console every time I reboot just to type exit.

1

when you see install CentOS screen, move the arrow up to "install CentOS 7" then press tab, It will show the parameter it is passing. remove the line until hd: and add "sr0" then press enter.

I think that will do it.

if didn't work, try to find the device name of the cdrom or USB mounted to install, Try ll /dev/disk/by-id/ you will get an idea which drive is device to append to hd: as mentioned.

0

If you can boot in rescue, you should regenerate initramfs. For example,

dracut -f /boot/initramfs-3.10.0-693.21.1.el7.x86_64.img 3.10.0-693.21.1.el7.x86_64

Thanks TrevorH for this solution: https://www.centos.org/forums/viewtopic.php?t=63988

Re: Change VM - 'Warning: dracut-initqueue timeout' at startup Post by TrevorH » 2017/09/08 16:08:32

All of the things you tried will not work. You need something like dracut -f /boot/initramfs-3.10.0-514.26.2.e17.x86_64.img 3.10.0-514.26.2.e17.x86_64

Pretty sure the message about vmxnet3 is a warning only and will not affect the outcome. That module is specific to a VMWare VM and won't be present anywhere else.

0

You can change this via rd.timeout option. There are several other timeouts which has been recently added, see: http://man7.org/linux/man-pages/man7/dracut.cmdline.7.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.