1

Grub 0.97 on my RHEL6 machine has thrown this error ever since I upgraded to the 2.6.32-642.6.2.el6.x86_64 kernel. I can boot previously installed versions of the kernel, but any kernel I installed after this will throw this error when grub boots that kernel. grub-install runs cleanly, and the disk is partitioned with just a / partition and a 2GB swap partition. The / partition has plenty of space and fsck runs cleanly.

I'm pretty sure this isn't an issue with grub.conf as I can boot the system on old kernels. Does anyone have any other ideas?

  • You should upgrade both your machine and your OS. Both are obsolete beyond believe. Your PC is so old as to have a BIOS limitation such as being unable to boot kernels residing after X GB after the beginning of the drive (not sure how much, this is a last century's problem). Older kernels are still within the allowed space, newer ones are outside the allowed space. The only workaround is to use a separated /boot partition at the very beginning of the drive. – user252181 Feb 7 '18 at 23:34
  • As much as I'd love to upgrade the OS, unfortunately, we are unable to upgrade the machine at this time. RHEL6 isn't EOL until 2020, so this is not unreasonable. It did end up being the size of the / partition. I just shrunk the / partition to 200GB (it was 1.7TB before) and that solved the problem. That was much easier than moving / to create a /boot partition. Thanks for the comment. – user274835 Feb 8 '18 at 0:57
1

It ended up being the size of the / partition. The / partition was 1.7TB and the BIOS isn't able to reference the entire partition as it's limited to a certain amount of GB starting with the beginning of the drive. I shrunk the / partition to 200GB and everything worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.