1

I have noticed a weird behavior in GNU screen session while using arrow keys. I'm sure it is caused because of a change in setting/configuration. I'm looking here for the root cause of it.

Problem caused: Whenever, I want to switch to view the list of the bash sessions in attached screen using arrow keys, I couldn't. I had to use number keys to move to different bash sessions. Also, while using VIM, I couldn't traverse using arrow keys.

Problem solution: I could fixed it using the reset command for GNU screen session I had.

However, I'm still not sure what caused the issue.

  • 1
    check the TERM settings in your shell, and in the screen tabs. If your terminal is being set to VT-100, or a terminal that doesn't interpret the arrow keys as arrows, that could be the culprit. Or it may be that screen is trying to set TERM to screen, but you don't have the screen termcap installed. Try running screen -T xterm and see if you get the expected behavior. – Tim Kennedy Feb 7 '18 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.