0

I have a problem with okular (or it is actually not a problem but irritating). Because of reasons I sometimes start okular from command line (zsh) and after I closed okular (sometimes after some seconds, not immediately which irritates me) it print something like:

schoenix:~$ okular file.pdf  
schoenix:~$ Creating the cache for:  "/home/schoenix/file.pdf"
Already in database?  true
      First update :  QDateTime(2018-01-22 15:14:58.000 CET Qt::TimeSpec(LocalTime))
       Last update :  QDateTime(2018-02-07 14:26:43.000 CET Qt::TimeSpec(LocalTime))
After the adjustment
     Current score :  9.14105
      First update :  QDateTime(2018-01-22 15:14:58.000 CET Qt::TimeSpec(LocalTime))
       Last update :  QDateTime(2018-02-07 14:26:43.000 CET Qt::TimeSpec(LocalTime))
Interval length is  3
         New score :  9.19105
ResourceScoreUpdated: "5ce27654-47a4-4b51-a7fd-f0d865917aff" "okular" "/home/schoenix/file.pdf"

After that it stops and I have to kill it via Ctrl+C, and sometimes it came some seconds later and I already typed a new command and it mixed with this output.

I want either disable the cache (how?) or disable this output.

  • Did my answer help? – Sparhawk Feb 10 '18 at 23:46
  • Had the same issue (openSuse 42.3) and traced it to kactivitymanagerd but found no proper solution. – Guest Jun 9 at 19:51
1

I don't see this with okular on my system (up-to-date Arch Linux, Okular 17.12.1-1). There is no output at all for me. Nevertheless, here are two options.

  1. Just close the terminal and open another one.
  2. Suppress all output with okular file.pdf >/dev/null

If the last is too annoying to type constantly, you could always make an alias. Put the following in ~/.zshrc:

alias okular='okular >/dev/null'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.