I have an external monitor connected thru an hdmi port to the dvi input of an external monitor. The monitor never gets detected. I run ubuntu 17.1 with intel video drivers; lspci -v finds:

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07) (prog-if 00 [VGA controller])
    Subsystem: Toshiba America Info Systems HD Graphics 520
    Flags: bus master, fast devsel, latency 0, IRQ 126
    Memory at c0000000 (64-bit, non-prefetchable) [size=16M]
    Memory at b0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 3000 [size=64]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915

The monitor is a samsung mega model BX2335, laptop is a toshiba tecra-z40-c, kernel is 4.13.0-32-generic. xrandr shows:

jeremy@jeremy-TECRA-Z40-C-pipl:~/Downloads$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 309mm x 174mm
   1920x1080     60.02*+  59.93  
   1680x1050     59.95    59.88  
   ....<a bunch of resolutions>....
   320x240       60.05  
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)

That first screen is the laptop screen. The xorg.conf looks ok afaict:

jeremy@jeremy-TECRA-Z40-C-pipl:~/Downloads$ more /usr/share/doc/xserver-xorg-video-intel/xorg.conf
Section "Device"
    Identifier "Intel"
    Driver "intel"
#   Option "AccelMethod" "uxa"

The monitors control panel doesn’t detect the external monitor. I've rebooted, run apt update, upgrade, and dist-upgrade, and tried the driver upgrades (none were found and I didn’t force anything) .


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.