-6

When I try to apt-get update it says:

Get:1 http://archive-3.kali.org/kali kali-rolling InRelease [30.5 kB]
Err:1 http://archive-3.kali.org/kali kali-rolling InRelease
The following signatures were invalid: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository <devel@kali.org>
Reading package lists... Done
W: GPG error: http://archive-3.kali.org/kali kali-rolling InRelease: The following signatures were invalid: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository <devel@kali.org>
E: The repository 'http://http.kali.org/kali kali-rolling InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

My /etc/apt/source.list looks like this:

deb http://http.kali.org/kali kali-rolling main contrib non-free
# For source package access, uncomment the following line
# deb-src http://http.kali.org/kali kali-rolling main contrib non-free
# deb cdrom:[Debian GNU/Linux 2017.3 _Kali-rolling_ - Official Snapshot amd64 L$

#deb cdrom:[Debian GNU/Linux 2017.3 _Kali-rolling_ - Official Snapshot amd64 LI$

What should I do ? thanks!

marked as duplicate by Rui F Ribeiro, Wouter Verhelst, Jeff Schaller, sebasth, G-Man Feb 7 '18 at 18:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3

Actually, your keys are outdated; you need to first update your keys. Try: wget -q -O - archive.kali.org/archive-key.asc | apt-key add and you’re good to go.

Check out their Tweet

Not the answer you're looking for? Browse other questions tagged or ask your own question.