1

I run Solaris 10 x86 in a VirtualBox for the purposes of maintaining a port of a freeware program.

From time to time when I want to search backwards and recall a Bash command with Ctrl-R, I accidentally hit something else, I think Win-R. The system promptly reboots. This looks like the same thing as that Stop-A on SparcStations.

What are the steps to disable this feature entirely or else remap it to something that isn't accidentally invoked?

Note: I'm not able to reproduce the behavior at will. It always happens by accident when I'm using only my left hand, trying to type LeftCtrl-R. I'm trying various key combinations to reproduce it on purpose, but none are perpetuating the reset. LeftWin-R brings up a program launching dialog box. (Could it be that this dialog takes the additional keystrokes that were intended for the Ctrl-R search and interprets them as a reboot command? However, don't remember seeing the dialog at all, not even a flash of it, at the time when these accidental reboots get triggered.)

The effect is an orderly reboot, completely different from the VirtualBox Host-R reset which uses the left control key and produces an instant, abrupt reset. The VirtualBox Host-H brings up a suspend/shutdown/cancel dialog box.

1 Answer 1

3

I accidentally hit something else, I think Win+R.

Unless you have changed the default, either you are hitting ⌘ Super+R which is the modifier key next door or you really are hitting ⎈ Control+R. Specifically in the latter case you are hitting ⎈ Right Control+R rather than ⎈ Left Control+R.

This is nothing to do with SparcStations or Solaris or the guest operating system at all; and everything to do with VirtualBox itself. ⎈ Right Control on most host operating systems or ⌘ Super on Mac OS are, by default, the Host Key in VirtualBox. In VirtualBox itself, Host+R resets the virtual machine, as if one had pressed a reset button on a physical machine.

Changing what key is the Host key is done from the preferences dialogue of the VirtualBox Manager under its "File" menu. (I personally prefer ⯉ Application Menu.) Making Host+R prompt before enacting the virtual reset button is done with "Reset all warnings" on the same menu. Clearly you checked the checkbox to prevent showing the warning dialogue some time ago, and are now being caught out by your own choice. (I gained the habit of never checking that checkbox for pretty much this reason.) ☺

2
  • I'm going for the left Ctrl key, to type Ctrl-R. Right hand not involved. Only happens in the Solaris VM which I use very rarely, never in a frequently used Ubuntu VM or others. Pretty sure this is a Solaris thing. Sun machines have Stop-R and they carried that into the x86 port.
    – Kaz
    Commented Feb 7, 2018 at 15:17
  • I just tried Host-R in the same Solaris VM. The behavior is completely different; it's an instant reset, like a power cycle on real hardware. Whatever I'm hitting, it perpetuates a graceful shutdown.
    – Kaz
    Commented Feb 7, 2018 at 15:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .