2

I have got a strange problem with gnome-terminal after upgrading from Linux Mint 17.3 to 18.3. Now, --working-directory does not work anymore. Eg:

gnome-terminal --working-directory=/home/user/Desktop/

instead opens in my home directory. This also means that "Open in terminal" from Nautilus file manager does not work.

If I create a new user and log in with that account, it works. So it must have something to do with gnome-terminal's configuration.

However, uninstalling and reinstalling gnome-terminal does not fix the problem, even with apt-get purge. I have also tried looking for something with dconf-editor.

Since this behavior breaks some of my important scripts, I would very much like to know how to fix it.

4

This is a known bug, and unfortunately has yet to be fixed.

If you have specified a custom command rather than your default shell to be run upon Gnome Terminal's startup, a potential fix is disabling the custom command:

Open the Gnome Terminal settings window and uncheck "Run custom command instead of my shell" to disable the option. This fix was mentioned by Jonathan Hartley in the comments section of the bug report, and fixed the issue for him.

  • I'm glad it worked! 😊 You should mark the answer as accepted. – aliceinpalth Feb 6 '18 at 22:06
  • 1
    Oops! I thought I marked it as accepted but I hit upvote instead. Done now. – marlar Feb 6 '18 at 23:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.