1

I am running Ubuntu 17.10 with Unity and i3. While configuring fonts for i3 at some point all of my fonts started looking very jaggy. I was using lxappearence to set my system fonts there. Both on i3 and Unity, the fonts on the system look horrible. But in applications like emacs and slack the fonts are perfect.

enter image description here

enter image description here

Here emacs has great rendering of the font.

enter image description here

Here are the things I have tried: 1) removed ~/.config/dconf/user 2) installed latest nvidia graphic drivers 3) removed the fonts I was using before this thing happened 4) I ran fc-cache -f -v

nothing seemed to work...

The output of xrdb -query

*customization: -color
Xft.dpi:    96
Xft.antialias:  1
Xft.hinting:    1
Xft.hintstyle:  hintmedium
Xft.rgba:   rgb
Xcursor.size:   24
Xcursor.theme:  DMZ-White

We can see that antialiasing is on. I experimented with it with different values in lxappearance but no success there,

Here is another strange thing. The first time this happened, only firefox browser content (not the url and the tabs) had destroyed fonts. After one reboot, the whole firefox with some other apps had ugly fonts (the system fonts were fine). After another reboot the system fonts all went to hell.

Please help as to how to fix my fonts problem.

1

After a while and after re-installed font-config, I found out what was the cause.

Since I am using both lxapperance and font-manager they have separate control over how fonts are rendered. If the anti-aliasing in lxappearance doesn't work, go to font-manger. Click -> Preferences -> Rendering -> Anti-aliasing and Hinting. Turn it on and immediately you should see how the fonts are aliased properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.