2

In my journal I see the following a few times a day:

kernel: wlp2s0: failed to remove key (1, ff:ff:ff:ff:ff:ff) from hardware (-22)

lspci reports:

02:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)

My kernel version is 4.14.15-1-MANJARO.

4

Kernel Bug 198357 - iwlwifi: failed to remove key (1, ff:ff:ff:ff:ff:ff) from hardware (-22) lists the issue as:

  • CLOSED CODE_FIX
  • Kernel Version: 4.15.0-rc6-00048-ge1915c8195b3
  • Regression: Yes

My hope is that this will be made available to earlier maintained kernel versions in the near future.

1
  • I have the same problem on 4.15.0-23-generic. It's an Ubuntu 18.04! – alisabzevari Jun 20 '18 at 10:21
1

I was having this issue when closing the lid of my laptop (entering 'suspended' mode). Once I opened the lid, wifi refused to connect and I was getting [ 183.188182] wlp60s0: failed to remove key (1, ff:ff:ff:ff:ff:ff) from hardware (-22). I tried lots of things and nothing worked. The only thing that really worked for me was restarting my router. I also answered a similar question here, in case someone needs more information: https://askubuntu.com/a/1014175/109449

1
  • This is the only thing that worked for me as well. Shutting down or rebooting my laptop did nothing. Booting into a different distro did nothing. Booting into Windows 10 DID allow me to get back online though. Resetting my internet router was the only thing that fixed it. This has happened on 2 occasions. Obviously something in the hardware (wifi card) which is stored even during reboots and shutdowns. – Delorean May 30 '18 at 1:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.