-1

it gives me this error:

Get:1 http://kali-za.bitcrack.net/kali kali-rolling InRelease [30.5 kB]
Err:1 http://kali-za.bitcrack.net/kali kali-rolling InRelease
  The following signatures were invalid: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository <devel@kali.org>
Reading package lists... Done
W: GPG error: http://kali-za.bitcrack.net/kali kali-rolling InRelease: The following signatures were invalid: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository <devel@kali.org>
E: The repository 'http://http.kali.org/kali kali-rolling InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

and this is my source list:

deb http://http.kali.org/kali kali-rolling main contrib non-free
# For source package access, uncomment the following line
# deb-src http://http.kali.org/kali kali-rolling main contrib non-free

marked as duplicate by Rui F Ribeiro, Jeff Schaller, dhag, Stephen Harris, DopeGhoti Feb 5 '18 at 18:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • according to the answer linked above, because it was not created to be able to do that. BUT just because a person does not know that, is not a reason to down vote them. They asked the question and hopefully now they know. – ctrl-alt-delor Feb 5 '18 at 17:13
1

You must download the GPG pubkey related to your error message :

wget -q -O - https://www.kali.org/archive-key.asc | gpg --import

It should work better with this :) BTW not tested on my side but the error message is pretty explicit.

Not the answer you're looking for? Browse other questions tagged or ask your own question.