0

I have a big, long running task on a SLES 12 server. I just tried using gstack on it, but the gstack processes don't seem to be getting any CPU - nothing on the screen after over 20 minutes. The machine doesn't seem to be particularly loaded (32 CPUs load of 2.4; 1TB RAM, 100G free). The process itself in top seems idle most of the time, with occasional bursts at around 200% CPU.

Any suggestions as to what is going on?

  • Do you get anything the strace? – Raman Sailopal Feb 5 '18 at 12:50
  • In the end I gave up. I don't think that strace will work when gstack/gdb is already attached. – Paul Floyd Feb 5 '18 at 12:55
  • Tried again, getting more or less the same thing. strace says "process XXX attached", and then nothing. The main process at this time is yoyoing on and off the CPU, but doesn't seem to be actually doing anything. Ctrl-C doesn't detach strace. – Paul Floyd Feb 5 '18 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.