0

I just recently ran a bash script that froze up my Linux mint machine, and I had no choice but to hold power key to perform a hard power off.

Now my machine will not boot.

I have no clue if the bash script did something, the hard reset did something, or it is just coincidence and my harddrive died.

I created a bash script as follows

for file in 4k/*
do
  convert $file -resize 50% 1080p/$file
done

I ran in the folder ~/Pictures/EastTrip/Finals/

When I ran this script the UI started to become unresponsive. Then I performed the hard reset.

At the same time I ran the script that was working on directory "4k", I had the program rawtherapee writing to the directory 4k. I can't help but feel like the file system is broke and not the harddrive.

I have entered recovery mode and dropped down to root shell. When I navigate to the Pictures directory and use ls command I get the following errors....

enter image description here

What have I done?!?! I have like a weeks of unsaved work :/

  • 5
    Looks like your hard drive may be failing. I don't think your script necessarily caused it although if it was performing a lot of processing on many large files it may have been enough strain to push it over the edge. – Jesse_b Feb 5 '18 at 4:32
  • @Jesse_b your comment seems the right answer to me. – andcoz Feb 5 '18 at 9:42
  • I see no reason to close this. Why the vote to close? – ctrl-alt-delor Feb 5 '18 at 17:02
1

Problems with "READ DMA" and "I/O error" are not problems with scripts, applications or the filesystem, but problems with the actual harddrive.

To answer your question: nothing in particular, but your harddrive is failing.

I can recommend turning the failing drive off for now, and later take a copy of whatever can be copied to a harddrive that is not failing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.