1

I reinstalled my system and now use KDE5 instead of KDE4. The system (e.g. in boot) uses the Compose Key I'm used to - Press Right Shift+Right Ctrl,a,e and I get æ.

But I'm unable to convince KDE to do so. In the KDE Keyboard expert settings I achived that it is now AltGr+Right Ctrl.

Question: How can I setup to either use system settings or set Right Shift+Right Ctrl as I'm used to?

  • are you running under wayland or x11? (env | grep XDG_SESSION_TYPE) .. if x11, what's the output of setxkbmap -query? – quixotic Feb 4 '18 at 10:49
  • loginctl says it's an x11 session althought I don't see any Xorg process anymore. Output is (rules: evdev / model: pc101 / layout: de / variant: nodeadkeys / options: compose:rctrl,compose:shift+rctrl,terminate:ctrl_alt_bksp,compose:rctrl-altgr) but only the last compose works (and the second is what I want). – Dirk Stöcker Feb 4 '18 at 15:13
  • Clearing options (setxkbmap -option) and (setxkbmap -option compose:shift+rctrl) does not work, but clearing and (setxkbmap -option compose:rctrl-altgr) restores behaviour, so default KDE5 is stealing shift+rctrl somewhere? – Dirk Stöcker Feb 4 '18 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.