4

I'm trying (and so far, failing) to find a solution to an issue I'm having. Some context, we have an assortment of different projectors, all HDMI, and an assortment of laptop hardware. The problematic projector in question is an InFocus IN126STa. What happens is when I plug in via HDMI, it picks up a signal from the laptop and I'll see something (sometimes it's extended mode, other times it's mirror), but the problem comes in when I switch modes -- say extended mode versus mirror. Almost all of the time, trying to switch the mode one time results in the InFocus projector going blank. The laptop however seems to respond as if it acknowledges the projector. I see the InFocus entry in display settings, I see the resolution, the framerate, the make/model, etc. It's just... nothing appears on the screen after trying to switch modes. I've tried this with other model projectors (namely Epson and NEC) but haven't ran into these issues.

The laptop hardware in question was tested on a Lenovo T470, Lenovo E570, and an Acer Travelmate TM113. The E570 is the almighty target machine to try and get working (hence why there's more mention of E570 below), but the Acer and T470 were just to compare. A rough list of what I've tried:

  • T470 with Ubuntu (Unity) 16.04 with Xorg
  • T470 with Ubuntu (Gnome) 16.04 with Xorg
  • E570 with Ubuntu (Gnome) 17.10 with Xorg
  • E570 with Ubuntu (Gnome) 17.10 with Wayland
  • Acer Travelmate TM113 with Ubuntu (Unity) 16.04 with Xorg
  • Three different types of HDMI cables
  • Upgrading the BIOS on the E570 to the latest version
  • Upgrading the firmware on the InFocus projector to the latest version
  • On the E570 with Ubuntu (Gnome) 17.10, I've tried the current Ubuntu kernel v4.13 along with the mainline 4.14 kernel and the mainline 4.15 kernel
  • Installed Antergos (Gnome) on the E570 and updated everything

All of the above resulted in the same experience: no change, problem still existed.

Here's where things got interesting... a colleague runs Fedora 27 with Gnome on a T470, so we tested that. Boom, worked fine. After that, I installed Fedora 27 with Gnome on the E570. Again, worked fine. The problem simply went away on Fedora. Projection with the InFocus projectors was a very consistent, stable experience.

At this point I'm trying to figure out what's different in the way Fedora 27 may handle Intel video on the E570/T470 than how Ubuntu/Antergos handle it. Something about Fedora is making this a far better experience, but given our target OS is Ubuntu, it makes me wonder what on earth it could be.

Based on this information, does anybody have any suggestions or further ideas to try? I appreciate any and all answers.

  • Probably different kernel version. Find the one on Fedora 27, and try to install the same one on the failing systems, or compile it. – Patrick Mevzek Feb 3 '18 at 5:56
  • We did try the same kernel. In fact 4.13 and 4.14 on Fedora worked fine while 4.13, 4.14, 4.15 did not on Ubuntu. All three kernels behaved the same on Ubuntu and exhibited the same issue. :( – JaSauders Feb 3 '18 at 6:06
  • There are issues with some graphic drivers for cheap Intel graphic cards when using frame buffer drivers, however from the discussion it does not seem the case. Dropping just an idea here. – Rui F Ribeiro Feb 3 '18 at 14:26
1

Partial answer:

As you have a working and a non-working system, it should be possible to figure out what's causing this.

First places to look are dmesg output and /var/log/Xorg.0.log after boot when X has started, to see which kernel drivers get loaded, and again after you plugged the projector in via HDMI. In that state, another interesting thing to look at is xrandr to see the names of your HDMI output, then x -q --verbose --output HDMI1 etc. for this output (with the correct name).

If you can't make sense of the logs, please upload both after a fresh boot and plugging in the projector to some place (e.g. pastebin), and edit question with a link.

Maybe that already gives a clue; if not, there are some more obscure places too look (e.g. EDID info).

Intel graphics card can use several different drivers, depending on the model. So please also edit the question to include the lspci -nn line for the graphics card to identify the exact model. It could be that Fedora and Ubuntu are using different drivers for that particular model, that would be the easiest case.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.