2

Beginning several weeks ago, and for reasons I can not clearly identify, I can not boot into Linux Mint 18.3.

With no solution, I reinstalled Linux Mint 18.3 and everything worked perfectly.

But several days ago, the same problem returned. The GRUB menu appears, and I can boot into Windows, but not into Linux.

When I try to boot into Linux, this message appears for a few seconds,

[0.000000] [Firmware bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0xb2 (or later) [0.868494] Couldn’t get size 0x800000000000000e [0.868497] MODSIGN: Couldn’t get UEFI db list

But, then I receive this message:

Welcome to emergency mode! After logging in,type "journalctl -xb" to view system logs, "systemctl reboot" to reboot, "systemctl default" or ^D to try again to boot into default mode. Give root password for maintenance (or type control-D to continue):

Solutions I have tried:

  1. In Windows 10, I have disabled Fastboot and hibernate, so that is not causing the problem.

  2. Restarted Windows 10, ran Checkdisk on all disks to ensure they have no errors.

  3. Installed and ran “boot-repair-disk”. It reports “Locked-ESP detected. You may want to retry after creating a /boot/efi partition (FAT32, 100MB~250MB, start of the disk, boot flag). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot/efi partition:] option of [Boot Repair].”

  4. I have removed the 3 NTFS drives that I use for data storage and tried booting only from the SSD drive that contains my Linux and Windows 10 dual boot system.

  5. I have used the BIOS-designated F12 to enter the boot sequence and have tried to boot directly into Linux. But the same error messages appear

None of these methods have fixed the problem. I have no idea how to proceed.

I suspect a solution is not so complex and the solution will be a lot faster than reinstalling Linux, Windows, and all my software.

My system is a dual boot running Linux Mint 18.3 and Windows 10:

  • Gigabyte GA-Z170X Gaming 5 motherboard
  • 32 gig RAM 500 gb SAMSUNG 850
  • EVO harddrive where Linux and Win 10 are installed.
  • three 4tb SeagateEnterprise NAS HDD ST4000VN0001 for data storage

Partitions Since I can't log into Linux, I'm not sure how to get a list of partitions according to Linux but in Windows 10, the partitions are listed as:

450 MB recovery partition 100 MB EFI System partition 199 GB NTFS partition (Windows 10 is installed here) 861 MB recovery partition 13 MB primary partition 262 GB EXT4 Linux (Mint 18 is installed here) 2.93 GB Linux swap

I ran a live Linux distro and installed "Boot-Repair-Disk" which was unable to solve the problem. I saved the output and can include it if its helpful in diagnosing the problem.

Boot-Repair-Disk reported:

Locked-ESP detected. You may want to retry after creating a /boot/efi partition (FAT32, 100MB~250MB, start of the disk, boot flag). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot/efi partition:] option of [Boot Repair].

Uisng gParted did not show any lock on any drive or partition. I have not been able to find a way to remove the ESP lock. How should I proceed?


Why did Boot-Repair-Disk create additional boot options?

On a side note, I am wondering however, why it added a number of items to my boot menu that were not there before. Now, when I reboot, my Z170X motherboard seems to boot twice before the GRUB menu appears.

My GRUB options now are

  • a. Linux Mint 18.3 Cinnamon 64-bit

    b. Advanced options for Linux Mint 18.3 Cinnamon 64-bit

    c. Windows UEFI bootmgfw.efi

    d. Windows Boot UEFI loader

    e. EFI/ubuntu/fbx64.efi

    f. EFI/ubunti/fwupx64.efi

    g. Windows Boot Manager (on /dev/sdd2)

    h. System setup

The options c, d, e, f, are all new after running Boot-Disk-Repair. Why are there are two options "c" and "d" to log into Windows? Nor do I understand what "e", "f" are for? Why did Boot-Repair-Disk create those entries?


Time problem

One other strange symptom is that the motherboard BIOS time and the time displayed in Widows is always wrong, but the date is correct. The time displayed is always 6 hours ahead of local time. When Linux was booting, it always showed the correct local time.

Whenever I tried to set the BIOS time to the correct time, it switches back to the incorrect time (6 hours fast) at next bootup. But the date is always correct. This leads me to believe there's nothing wrong with my CMOS battery. Why is this happening and is it related to my problem?

More importantly, how can I prevent this from happening in the future? Is there some problem with the way I partitioned the drives and installed Linux?

  • On the note of the system time, check man7.org/linux/man-pages/man8/hwclock.8.html , more specifically the section labeled 'LOCAL vs. UTC'. Your hardware clock is currently set to UTC, but Windows thinks it's set according to your local time zone, and the firmware doesn't care about timezones, so they both display the time as-is. As far as the main issue, I don't think it has anything to do with the EFI system partition, 'Emergency Mode' usually means that the system can't find the root filesystem. – Austin Hemmelgarn Feb 2 '18 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.