1

I have Debian Stretch (xfce) and my touchpad doesn't react to tap.

I searched some solutions to fix it, example:

  • create 50-synaptics.conf to /etc/X11/Xsession.d/ and /usr/share/X11/xorg.conf.d/

50-synaptics.conf

Section “InputClass”
        Identifier  “touchpad catchall”
        Driver  “synaptics”
        MatchIsTouchpad “on”
MatchDevicePath “/dev/input/event*”
        Option  “TapButton1”  “1”
        Option  “TapButton2”  “2”
        Option  “TapButton3”  “3”

But If I try something solution, I every get crash with starting Light-Display-Manager.

I have to delete 50-synaptics.conf and reboot notebook.

So can I fix my problem with touchpad?

  • Have you tried renaming the file to just synaptics.conf? Also, are you able to try configuration through synclient? It should be installed alongside synaptics. – aliceinpalth Feb 3 '18 at 2:35
-1

Debian 9 "Stretch" is using libinput driver

$ mkdir -p /etc/X11/xorg.conf.d
$ echo 'Section "InputClass"
    Identifier "libinput touchpad catchall"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Driver "libinput"
    Option "Tapping" "on"
EndSection' > /etc/X11/xorg.conf.d/40-libinput.conf
$ systemctl restart lightdm

From Debian Wiki

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.