I'm new to Linux so this point is surely clear to all Linux professionals however I could not google it...
I was logged into my Ubuntu machine while several programs were open / processes running.
I wished to close them all simply by restarting the machine similarly to Windows however they appearing to still be active after the machine restart / shutdown-start.
For example after restarting I tried to open Chrome and received notification that the Chrome profile is locked by currently running process started by another user (who is me too, but before the restart).
So is it possible to really, actually close all the processes by reboot here similarly to Windows?
ps aux | grep [c]hromium presents the following:

eliyahu   2737  5.6  1.2 1433268 210776 ?      SLl  18:39   2:21 chromium-browser --enable-pinch
eliyahu   2750  0.0  0.4 673808 75232 ?        S    18:40   0:00 chromium-browser --type=zygote
eliyahu   2752  0.0  0.0 673808 13836 ?        S    18:40   0:00 chromium-browser --type=zygote
eliyahu   2800  2.7  1.9 1310252 314540 ?      Sl   18:40   1:10 chromium-browser --type=gpu-process --channel=2737.0.1092352317 --window-depth=24 --supports-dual-gpus=false --gpu-driver-bug-workarounds=3,16,54 --disable-gl-extensions=GL_ARB_occlusion_query GL_ARB_occlusion_query2 --disable-accelerated-video-decode --gpu-vendor-id=0x8086 --gpu-device-id=0x5916 --gpu-driver-vendor --gpu-driver-version --v8-natives-passed-by-fd --v8-snapshot-passed-by-
eliyahu   2802  0.0  0.0 723920 16088 ?        S    18:40   0:00 chromium-browser --type=gpu-broker
eliyahu   2850  0.2  0.5 1100488 87836 ?       Sl   18:40   0:06 /usr/lib/chromium-browser/chro
eliyahu   2929  0.8  0.8 1170260 136412 ?      Sl   18:41   0:20 /usr/lib/chromium-browser/chro
eliyahu   3019  0.9  1.6 1409344 270364 ?      Sl   18:42   0:23 /usr/lib/chromium-browser/chro
eliyahu   3062  1.1  1.8 1464292 299432 ?      Sl   18:42   0:26 /usr/lib/chromium-browser/chro
eliyahu   3263  3.0  1.5 1720096 257880 ?      Sl   18:44   1:08 /usr/lib/chromium-browser/chro
eliyahu   3353  1.0  0.8 1163924 142816 ?      Sl   18:45   0:22 /usr/lib/chromium-browser/chro
eliyahu   3763  8.6  1.0 1206684 166060 ?      Sl   18:52   2:36 /usr/lib/chromium-browser/chro
  • 1
    Please clarify how you restarted. Unlike recent versions of Windows which do actually act as you describe since "restart" actually goes into hibernation instead of shutting down, Linux machines will actually restart, stopping any running process. Did you force the restart perhaps? So that chrome didn't have time to shut down gracefully? – terdon Feb 1 '18 at 17:14
  • Upper-right corner icon -> Shut Down ->Restart (or Shut Down) – Eliyahu Feb 1 '18 at 17:18
  • 1
    So did you start chrome? or did it start it self? – ctrl-alt-delor Feb 1 '18 at 17:35
  • For example after restarting I tried to open Chrome and received notification that the Chrome profile is locked by currently running process Often in linux a program when it is launched or running will have created some kind of file somewhere, the name can vary but if this lock file exists then the program can interpret that as the program is running. When the program or system shuts down cleanly, the lock file should be removed but that may not always happen – ron Feb 1 '18 at 17:39

short answer

All process are stopped at shutdown. They are not restarted.

longer answer

  • There maybe a session manager restarting user applications on login.
  • Services are restarted (but I don't think this is what you are seeing).
  • A program may have written a lock to a file, files are not deleted on reboot. That would be bad. (These files should be kept it a tmp filesystem and deleted on reboot). Therefore you need to find out if chrome is running, or there is just a lock file. Run a process viewer to see if chrome is running.
  • So, if I understand you clearly, Linux does similar to Windows in this point, processes are stopped by rebooting. Hm, still need to understand if is it OK when I see such a notification after restart or not.... – Eliyahu Feb 1 '18 at 17:16
  • Have a look is chrome listed when you get a process list. You can check on the command line with ps aux | grep [c]hrome What does this show? – ctrl-alt-delor Feb 1 '18 at 17:19
  • it is too long to paste here :( – Eliyahu Feb 1 '18 at 17:23
  • Done. As you can see I use Chromium but it's not make thing different. – Eliyahu Feb 1 '18 at 17:31
  • Do not understand “it's not make thing different“ – ctrl-alt-delor Feb 1 '18 at 17:36

Either something is automatically restarting Chrome when it shouldn't, either that's because your desktop environment saves your last session (currently launched applications) to automatically restart the programs -as "intended".

I strongly suspect the latter's.


What's your desktop environment ?

Despite you saying that you're running Ubuntu, we're not quite sure that you're running the standard Ubuntu flavor or one of its derivatives (Kubuntu, Xubuntu, etc).

  • The most standard, regular and the mainstream Ububtu 16.04 LTS – Eliyahu Feb 4 '18 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.