7

On an apt-get update I got the common error:

W: Failed to fetch http://dl.google.com/linux/earth/deb/dists/stable/Release Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file)

Per the answers on other questions, I changed the /etc/apt/sources.list.d/google-earth.list file to include the [arch=amd64] part to it. However, as the file itself warns,

THIS FILE IS AUTOMATICALLY CONFIGURED

You may comment out this entry, but any other modifications may be lost.

so that I have to change it every now and then.

How can I make that change permanent?

1 Answer 1

4

Good question :). I had a related problem on Fedora, so I did the equivalent of renaming google-earth.list to my-google-earth.list (or maybe google-earth-amd64.list) before editing it.

From Google's point of view, the user had deleted google-earth.list, and they avoid recreating it. In case you wanted to disable updates, I guess.

You might prefer to leave google-earth.list in place instead, but comment out the line, and then create a copy my-google-earth.list which has your own version of the line.

Both approaches could be a bit confusing. I think my approach felt less confusing to me, because I'd written script (an Ansible role) where I could save a comment why I was doing this.


# If we create google-chrome.repo ourself, the package wants to reset baseurl.
# Whereas if google-chrome.repo does not exist, it is considered to be deleted
# or otherwise disabled by user action.  It will not be recreated.  So we can
# set up our own local-google-chrome.repo.
2
  • But where is the original .list file configured from? Which process does that?
    – rustyx
    Commented Nov 13, 2022 at 11:59
  • /etc/cron.daily/google-chrome
    – sourcejedi
    Commented Nov 13, 2022 at 12:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .