I am using an Ubuntu 16.04 LTS. I ran into an unusual problem with my disk usage. Some of my applications were aborted with the message on the terminal stating "not enough disk space available".

The following is the out put of

df -hT

Filesystem     Type      Size  Used Avail Use% Mounted on
udev           devtmpfs  5.7G     0  5.7G   0% /dev
tmpfs          tmpfs     1.2G  9.6M  1.2G   1% /run
/dev/nvme0n1p7 ext4       69G   66G   40M 100% /
tmpfs          tmpfs     5.8G  102M  5.7G   2% /dev/shm
tmpfs          tmpfs     5.0M  4.0K  5.0M   1% /run/lock
tmpfs          tmpfs     5.8G     0  5.8G   0% /sys/fs/cgroup
/dev/nvme0n1p1 vfat      256M   32M  225M  13% /boot/efi
tmpfs          tmpfs     1.2G   84K  1.2G   1% /run/user/1000

My ext4 partition seems to be used up 100% and I find that it is mounted on '/'. I don't know if this is unusual. Before typing the df -hT command, I checked gparted and found that ext4 was mounted on /var/lib/docker/aufs. So hastily I uninstalled docker (since I wasn't using it anyways) and now it shows as '/'.

Also, while trying to find out what is consuming the space, I found that /tmp consumes 15G. But I am not sure how to free that. Any help regarding this is appreciated. Thanks.

up vote 0 down vote accepted
  1. It is not only normal for a filesystem to be mounted as /, it is mandatory.
  2. It is common for the root filesystem to be ext4.
  3. To free the space used in /tmp:
    • cd /tmp.
    • ls -la.  Look at the files and see whether any of them are important (they shouldn’t be), and try to figure out if they are being used by running processes.
    • rm -r *, or rm everything except the ones you don’t want to remove.  You may need to use sudo to get all the files, but, if so, try to figure out why.  Are there files there that are owned by other people?
    • If possible, you might want to reboot before doing the above.  This might just clear out /tmp all by itself.  And, even if it doesn’t, it should clear out any processes that might be using files in /tmp.
  • The reboot option worked. The disk usage is only 79% now. Thanks for that. And regarding the file system, I thought it should be mounted on /Dev/sda4 (or may be I remember seeing it somewhere). I still couldn't understand why it showed /var/lib/docker/aufs. Any idea regarding that? – Jayanth Feb 1 at 5:29
  • Filesystems are on devices — /dev/something — and are mounted on directories, such as /, /home, /usr, /boot, /mnt, etc.  For some reason, your root filesystem (the one mounted on /) is on /dev/nvme0n1p7.  Why that is the device name, rather than /dev/sda4, is determined by what kind of storage device(s) you have and how they are connected.  I don’t know what nvme means (Network Volume Manager?); you could Google it. … (Cont’d) – G-Man Feb 1 at 5:56
  • (Cont’d) …  I don’t know exactly how /var/lib/docker/aufs fits in.  I guess it means you were using it in Docker; I don’t know much about Docker. But you know that ext4 is a filesystem type, right?  You can have more than one ext4 filesystem.  Was /dev/nvme0n1p7 mounted as /var/lib/docker/aufs?  If it was some other device (partition), it is probably irrelevant to your “not enough disk space available” problem. – G-Man Feb 1 at 5:56
  • @G-Man NVMe is NVM Express: it was renamed by udev's persistent naming rules. – ErikF Feb 1 at 6:33
  • @G-Man yes it was /dev/nvme0n1p7 mounted as /var/lib/docker/aufs. I installed docker once but never used it (so uninstalled it after seeing this problem). [forums.docker.com/t/var-lib-docker-aufs-diff-out-of-disk-space/… shows that this has something to do with docker version. They say it is fixed after the update. – Jayanth Feb 4 at 22:05

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.