1

After installing privoxy I started it up and, after directing my browser to run through it as a proxy, I was presented with an error saying the following

"There is no Internet connection

There is something wrong with the proxy server, or the address is incorrect."

Fair enough, I decided to check the log file and see what is going on, but there is absolutely nothing in the log file.

Upon checking the config file, I see that I have the following settings

...
logdir /var/log/privoxy    
logfile logfile
debug     1 # Log the destination for each request Privoxy let through. See also debug 1024.
debug  1024 # Actions that are applied to all sites and maybe overruled later on.
debug  4096 # Startup banner and warnings
debug  8192 # Non-fatal errors
...

Alright, so it says that is should be logging to the file logfile in the directory /var/log/privoxy. I check the permissions and find

drwxr-xr-x  2 privoxy privoxy            4096 Jan 31 16:18 privoxy

So it's not a permissions issue. I have uninstalled and reinstalled to no avail. I have no idea why it isn't working. It is logging to the system journal but I hate having to dig through that for stuff.

For context, I am running Arch Linux.

I found that if I manually start it via

sudo privoxy --user privoxy --no-daemon /etc/privoxy/config

that it runs just fine. So I have determined it is a systemd issue. Below is the default systemd file

[Unit]
Description=Privoxy Web Proxy With Advanced Filtering Capabilities
After=network.target

[Service]
User=privoxy
Type=simple
ExecStart=/usr/bin/privoxy --no-daemon /etc/privoxy/config
PrivateDevices=yes

[Install]
WantedBy=multi-user.target
1

Seems to be a packaging issue: https://bugs.archlinux.org/task/54570

Have a look at: https://github.com/systemd/systemd/pull/7198

Try this systemd unit file:

[Unit]
Description=Privoxy Web Proxy With Advanced Filtering Capabilities   
After=network.target   

[Service]
#User=privoxy
#Type=simple
#ExecStart=/usr/bin/privoxy --no-daemon /etc/privoxy/config
#PrivateDevices=yes

Type=forking
PIDFile=/var/run/privoxy.pid
ExecStart=/usr/bin/privoxy --pidfile /var/run/privoxy.pid --user privoxy.privoxy /etc/privoxy/config
ExecStop=/usr/bin/rm /var/run/privoxy.pid
SuccessExitStatus=15
StandardOutput=file:/var/log/privoxy/logfile
StandardError=file:/var/log/privoxy/logfile

[Install]
WantedBy=multi-user.target

https://git.archlinux.org/svntogit/community.git/tree/trunk?h=packages/privoxy

  • I am still struggling with this (as in, still to this day). Thank you for this! – T-he-game May 11 '18 at 23:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.