1

I am experiencing problems with compiling autoconf and they probably are related to the version of the M4 that I am using. I will put part of the result of running both ./configure as running ./make so someone can confirm is the cause is really that and what I should do to fix it (probably moving to another version of it). If someone wants the full output of any, I will put i.

The M4 version is 1.4.10 and the autoconf is 2.64.

./configure --prefix=/media/34GB/Arquivos-de-Programas-Linux/Autoconf-2.64/ --exec-prefix=/media/34GB/Arquivos-de-Programas-Linux/Autoconf-2.64/

checking for GNU M4 that supports accurate traces... /usr/local/bin/m4

checking whether /usr/local/bin/m4 accepts --gnu... no

configure: WARNING: The version of M4 that was found does not support -g.

configure: WARNING: Using it with POSIXLY_CORRECT set may cause problems.

checking how m4 supports trace files... --debugfile

make

make[3]: Entering directory /media/34GB/Arquivos-de-Programas-Linux/autoconf-2.64/lib/m4sugar' :;{ \ echo '# This file is part of -*- Autoconf -*-.' && \ echo '# Version of Autoconf.' && \ echo '# Copyright (C) 1999, 2000, 2001, 2002, 2006, 2007, 2009' && \ echo '# Free Software Foundation, Inc.' && \ echo &&\ echo 'm4_define([m4_PACKAGE_NAME], [GNU Autoconf])' && \ echo 'm4_define([m4_PACKAGE_TARNAME], [autoconf])' && \ echo 'm4_define([m4_PACKAGE_VERSION], [2.64])' && \ echo 'm4_define([m4_PACKAGE_STRING], [GNU Autoconf 2.64])' && \ echo 'm4_define([m4_PACKAGE_BUGREPORT], [bug-autoconf@gnu.org])' && \ echo 'm4_define([m4_PACKAGE_URL], [http://www.gnu.org/software/autoconf/])' && \ echo 'm4_define([m4_PACKAGE_YEAR], ['sed 's/^([0-9][0-9][0-9][0-9])./\1/;q' ../../ChangeLog'])'; \ } > version.m4-t mv version.m4-t version.m4 make[3]: Leaving directory/media/34GB/Arquivos-de-Programas-Linux/autoconf-2.64/lib/m4sugar' autom4te_perllibdir='..'/lib AUTOM4TE_CFG='../lib/autom4te.cfg' ../bin/autom4te -B '..'/lib -B '..'/lib --language M4sh --cache '' --melt ./autoconf.as -o autoconf.in %n in writable segment detected Aborted autom4te: /usr/local/bin/m4 failed with exit status: 134 make[2]: [autoconf.in] Error 134 make[2]: Leaving directory /media/34GB/Arquivos-de-Programas-Linux/autoconf-2.64/bin' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory/media/34GB/Arquivos-de-Programas-Linux/autoconf-2.64' make: * [all] Error 2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.