1

I am trying to debug an issue that happens all the time. NetworkManager is running and upon connecting to a network, I am using a dispatcher script to setup my firewall rules (shorewall, and it is set to run asynchronously). As soon as shorewall sets up the rules, NetworkManager crashes:

NetworkManager segfault at 8 ip 00007fa89e102e16 sp 00007fff51f34be8 error 4 in libc-2.23.so[7fa89e084000+18e000]

I don't understand why shorewall / iptables would have a direct impact here. I tried cutting back my ruleset from shorewall and it still crashes. Lastly, I disabled shorewall altogether and went with a very plain iptables script, and that worked without issue. Shorewall is also configuring QOS, so there are other things going on, but I still am having a tough time believing that there could be a direct link.

Also, if I revert back to an older version of NetworkManager 1.4.4-r1, I don't have any issues. Lastly, I also manually reverted back to the prior working version of shorewall while keeping NetworkManager at 1.10.2 and that had no impact. So, I don't believe it is an issue with shorewall, but instead something NetworkManager is doing differently.

I tried to use strace here, but I'm not making heads or tails out of the output.

What else can I do to sort this out?

0

I reverted back to NetworkManager 1.4.4-r1 and the problem appears to go away. I will file a bug report with NetworkManager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.