1

I am having issues installing virtualbox on my kali-rolling dist (Linux kali 4.12.0-kali1-amd64 #1 SMP Debian 4.12.6-1kali6 (2017-08-30) x86_64 GNU/Linux).

My main goal is to setup metasploitable3 (https://github.com/rapid7/metasploitable3).

I have installed packer and vagrant:

root@kali:~/Desktop/metasploitable3# packer -v
1.1.3
root@kali:~/Desktop/metasploitable3# vagrant -v
Vagrant 2.0.1

I have purged vitualbox and reinstalled for the sake of demonstration:

root@kali:~/Desktop/metasploitable3# sudo apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') virtualbox dkms virtualbox-dkms
Reading package lists... Done
Building dependency tree       
Reading state information... Done
linux-headers-amd64 is already the newest version (4.14+89+kali1).
Suggested packages:
  python3-apport vde2 virtualbox-guest-additions-iso
The following NEW packages will be installed:
  dkms virtualbox virtualbox-dkms virtualbox-qt
0 upgraded, 4 newly installed, 0 to remove and 273 not upgraded.
Need to get 0 B/26.2 MB of archives.
After this operation, 111 MB of additional disk space will be used.
Selecting previously unselected package dkms.
(Reading database ... 343278 files and directories currently installed.)
Preparing to unpack .../archives/dkms_2.3-3_all.deb ...
Unpacking dkms (2.3-3) ...
Selecting previously unselected package virtualbox-dkms.
Preparing to unpack .../virtualbox-dkms_5.2.6-dfsg-2_all.deb ...
Unpacking virtualbox-dkms (5.2.6-dfsg-2) ...
Selecting previously unselected package virtualbox.
Preparing to unpack .../virtualbox_5.2.6-dfsg-2_amd64.deb ...
Unpacking virtualbox (5.2.6-dfsg-2) ...
Selecting previously unselected package virtualbox-qt.
Preparing to unpack .../virtualbox-qt_5.2.6-dfsg-2_amd64.deb ...
Unpacking virtualbox-qt (5.2.6-dfsg-2) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-2) ...
Processing triggers for menu (2.1.47+b1) ...
Setting up dkms (2.3-3) ...
Processing triggers for systemd (236-3) ...
Processing triggers for man-db (2.7.6.1-4) ...
Processing triggers for shared-mime-info (1.9-2) ...
Processing triggers for gnome-menus (3.13.3-11) ...
Processing triggers for hicolor-icon-theme (0.17-1) ...
Setting up virtualbox-dkms (5.2.6-dfsg-2) ...
Loading new virtualbox-5.2.6 DKMS files...
Building for 4.12.0-kali1-amd64
Module build for kernel 4.12.0-kali1-amd64 was skipped since the
kernel headers for this kernel does not seem to be installed.
Setting up virtualbox (5.2.6-dfsg-2) ...
vboxweb.service is a disabled or a static unit, not starting it.
Job for virtualbox.service failed because the control process exited with error code.
See "systemctl status virtualbox.service" and "journalctl -xe" for details.
invoke-rc.d: initscript virtualbox, action "restart" failed.
● virtualbox.service - LSB: VirtualBox Linux kernel module
   Loaded: loaded (/etc/init.d/virtualbox; generated; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2018-01-31 10:15:25 CST; 7ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 22278 ExecStart=/etc/init.d/virtualbox start (code=exited, status=1/FAILURE)

Jan 31 10:15:25 kali systemd[1]: Starting LSB: VirtualBox Linux kernel module...
Jan 31 10:15:25 kali virtualbox[22278]: Loading VirtualBox kernel modules...No suitable module for running kernel found ... failed!
Jan 31 10:15:25 kali virtualbox[22278]:  failed!
Jan 31 10:15:25 kali systemd[1]: virtualbox.service: Control process exited, code=exited status=1
Jan 31 10:15:25 kali systemd[1]: virtualbox.service: Failed with result 'exit-code'.
Jan 31 10:15:25 kali systemd[1]: Failed to start LSB: VirtualBox Linux kernel module.
Setting up virtualbox-qt (5.2.6-dfsg-2) ...
Processing triggers for systemd (236-3) ...
Processing triggers for menu (2.1.47+b1) ...

After this, I am capable of running the virtualbox GUI. But when I want to execute the metasploitable3 build script I get the following error:

root@kali:~/Desktop/metasploitable3# ./build_win2008.sh
./build_win2008.sh: line 14: cha: command not found
./build_win2008.sh: line 27: [[: WARNING:: syntax error in expression (error token is ":")
./build_win2008.sh: line 31: [[: WARNING:: syntax error in expression (error token is ":")
Compatible version of VirtualBox found.
Compatible version of packer was found.
Correct version of vagrant was found.
Compatible version of vagrant-reload plugin was found.
All requirements found. Proceeding...
Building the Vagrant box...
virtualbox-iso output will be in this color.

Build 'virtualbox-iso' errored: Error reading version for guest additions download: VirtualBox is not properly setup: WARNING: The character device /dev/vboxdrv does not exist.
     Please install the virtualbox-dkms package and the appropriate
     headers, most likely linux-headers-amd64.

     You will not be able to start VMs until this problem is fixed.
5.2.6_Debianr120293

==> Some builds didn't complete successfully and had errors:
--> virtualbox-iso: Error reading version for guest additions download: VirtualBox is not properly setup: WARNING: The character device /dev/vboxdrv does not exist.
     Please install the virtualbox-dkms package and the appropriate
     headers, most likely linux-headers-amd64.

     You will not be able to start VMs until this problem is fixed.
5.2.6_Debianr120293

==> Builds finished but no artifacts were created.
Error building the Vagrant box using Packer. Please check the output above for any error messages.Error reading version for guest additions download: VirtualBox is not properly setup: WARNING: The character device /dev/vboxdrv does not exist.
 Please install the virtualbox-dkms package and the appropriate
 headers, most likely linux-headers-amd64.

 You will not be able to start VMs until this problem is fixed. 5.2.6_Debianr120293

More specifically:

Error reading version for guest additions download: VirtualBox is not properly setup: WARNING: The character device /dev/vboxdrv does not exist.
     Please install the virtualbox-dkms package and the appropriate
     headers, most likely linux-headers-amd64.

     You will not be able to start VMs until this problem is fixed.
5.2.6_Debianr120293

It seems that an error in my install has caused an error later on with virtualbox-dkms. I have found other issues similar to this, but no fixes have worked.

Thanks.

  • I see that there are build issues using versions of vagrant newer than 1.9.1 and you are using 2.0.1. Did you try downgrading vagrant? – bu5hman Feb 1 '18 at 17:33
  • I just tried the same process (reinstalled virtualbox) with 1.9.1 but unfortunately it get the same errors. – Alex Beam Feb 1 '18 at 19:03
  • Do you have guest additions installed in your virtualbox? – bu5hman Feb 3 '18 at 15:23
  • Guest additions are not relevant, as the problem is in running the VirtualBox host. – telcoM Feb 4 '18 at 21:10
0
Loading new virtualbox-5.2.6 DKMS files...
Building for 4.12.0-kali1-amd64
Module build for kernel 4.12.0-kali1-amd64 was skipped since the
kernel headers for this kernel does not seem to be installed.

and later:

Please install the virtualbox-dkms package and the appropriate
    headers, most likely linux-headers-amd64.

So virtualbox-dkms is installed, but linux-headers-amd64 with a version number exactly matching your running kernel package is not. Fix that, and then use the dkms command to build the virtualbox kernel modules.

0

Just tried this on my machine.

You need to download and install

virtual-guest-add 5.2.6-1 (current version in the rolling repo)

which packer expects to find in

/usr/share/virtualbox/VBoxGuestAdditions.iso

To save waiting for the script, you can also download the iso from

http://download.microsoft.com/download/7/5/E/75EC4E54-5B02-42D6-8879-D8D3A25FBEF7/7601.17514.101119-1850_x64fre_server_eval_en-us-GRMSXEVAL_EN_DVD.iso

which packer looks for in

whereverYouPutIt/metasploitable3/iso/

...... that's as far as i have got so far (waiting for the iso) but grabbing guest additions should cure your immediate problem.

EDIT

As you are running virtualbox 5.2 you will probably need to make this adjustment to the configuration files.

In the build I made yesterday I also had to make this adjustment as the wamp.bat current script cloned from the git repository points to a dead wamp link and causes the build to fail.

I also had to explicitly add the .box file to vagrant

vagrant box add -f metasploitable3 /path/to/build/metasploitable3/windows_2008_r2_virtualbox.box
vagrant up

This worked witj

virtualbox 5.2.6
$packer -v
1.0.4
$vagrant -v
Vagrant 1.9.1
$ uname -a
Linux kali 4.13.0-kali1-amd64 #1 SMP Debian 4.13.13-1kali1 (2017-11-17) x86_64 GNU/Linux

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.