0

I try to compile PySide2 on my centos 7 I already successfully compiled Qt5.10 and Cmake 3.10.2 Then I clone PySide5.6 from git, and use this command to cmpile PySide2:

python setup.py install --qmake=/apps/shared/qt5/5.10.0/bin/qmake --cmake=/apps/shared/cmake/3.10.2/bin/cmake --prefix=/tmp/5.6 --jobs=12

But It always casts a error :

**c++: error: /home/isaac/Desktop/studio/pyside-setup/pyside2_build/py2.7-qt5.10.1-64bit-release/pyside2/PySide2/QtCore/PySide2/QtCore/qabstractstate_wrapper.cpp: No such file or directory c++: fatal error: no input files

c++: error: /home/isaac/Desktop/studio/pyside-setup/pyside2_build/py2.7-qt5.10.1-64bit-release/pyside2/PySide2/QtCore/PySide2/QtCore/qabstracttransition_wrapper.cpp: No such file or directory compilation terminated. make[2]: *** [PySide2/QtCore/CMakeFiles/QtCore.dir/PySide2/QtCore/qabstractstate_wrapper.cpp.o]

Error 4 c++: fatal error: no input files

make[2]: * Waiting for unfinished jobs.... compilation terminated. make[2]: [PySide2/QtCore/CMakeFiles/QtCore.dir/PySide2/QtCore/qabstracttransition_wrapper.cpp.o] Error 4 [ 4%] Building CXX object PySide2/QtCore/CMakeFiles/QtCore.dir/PySide2/QtCore/qabstractitemmodel_wrapper.cpp.o make[1]: [PySide2/QtCore/CMakeFiles/QtCore.dir/all] Error 2 make: * [all] Error 2 error: Error compiling pyside2 **

This problem has already bothered me for 4 days! Did I make something wrong ? How can I fix this?

0

PySide2 5.6 does't support Qt5.10.0.So if you want using Qt5.10.0 you must upgrade PySide2 to 5.9.And one more useful detail, the CMakeLists.txt under

~/pyside-setup/sources/shiboken2

require clang 3.9 and llvm 3.9, but if you are using 3.9 version to compile PySide2 it would cast a error:

shiboken: Error running ApiExtractor.

You need upgrade Clang 5.0 and llvm 5.0 to compile PySide2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.