1

I have been trying to establish a connection to a remote server controlled by a hosting company. I provided them with my .pub file and they say that it has been added to the authorized_keys file on the server. My connection always seems to default back to password authentication. I am in contact with the hosting company as I believe this to be a problem on their end, but I want to ensure that I have done everything properly.

The output of ssh -vvv is as follows:

OpenSSH_7.2p2 Ubuntu-4ubuntu2.4, OpenSSL 1.0.2g  1 Mar 2016
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: resolving "aqua2.nmsrv.com" port 22
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to aqua2.nmsrv.com [208.70.245.240] port 22.
debug1: Connection established.
debug1: identity file /home/karst/.ssh/id_rsa type 1
debug1: key_load_public: No such file or directory
debug1: identity file /home/karst/.ssh/id_rsa-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.2p2 Ubuntu-4ubuntu2.4
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.7p1-hpn14v5
debug1: match: OpenSSH_6.7p1-hpn14v5 pat OpenSSH* compat 0x04000000
debug2: fd 3 setting O_NONBLOCK
debug1: Authenticating to karstsrv.nmsrv.com:22 as 'karst'
debug3: hostkeys_foreach: reading file "/home/karst/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /home/karst/.ssh/known_hosts:4
debug3: load_hostkeys: loaded 1 keys from karstsrv.nmsrv.com
debug3: order_hostkeyalgs: prefer hostkeyalgs: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521
debug3: send packet: type 20
debug1: SSH2_MSG_KEXINIT sent
debug3: receive packet: type 20
debug1: SSH2_MSG_KEXINIT received
debug2: local client KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,ext-info-c
debug2: host key algorithms: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-ed25519-cert-v01@openssh.com,ssh-rsa-cert-v01
@openssh.com,ssh-ed25519,rsa-sha2-512,rsa-sha2-256,ssh-rsa
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,aes192-cbc,aes256-cbc,3des-cbc
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,aes192-cbc,aes256-cbc,3des-cbc
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com,zlib
debug2: compression stoc: none,zlib@openssh.com,zlib
debug2: languages ctos:
debug2: languages stoc:
debug2: first_kex_follows 0
debug2: reserved 0
debug2: peer server KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1,diffie-hellman-group-exchange-sha1,diffie-hellman-group1-sha1
debug2: host key algorithms: ssh-rsa,ssh-dss,ecdsa-sha2-nistp256,ssh-ed25519
debug2: ciphers ctos: aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,chacha20-poly1305@openssh.com
debug2: ciphers stoc: aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,chacha20-poly1305@openssh.com
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com
debug2: compression stoc: none,zlib@openssh.com
debug2: languages ctos:
debug2: languages stoc:
debug2: first_kex_follows 0
debug2: reserved 0
debug1: kex: algorithm: curve25519-sha256@libssh.org
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug3: send packet: type 30
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug3: receive packet: type 31
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:/3mOxCAhieumccJeTzF2bUHKWMVmcvOgZAd6Ut5gBXc
debug3: hostkeys_foreach: reading file "/home/karst/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /home/karst/.ssh/known_hosts:4
debug3: load_hostkeys: loaded 1 keys from karstsrv.nmsrv.com
debug3: hostkeys_foreach: reading file "/home/karst/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /home/karst/.ssh/known_hosts:5
debug3: load_hostkeys: loaded 1 keys from 208.70.245.240
debug1: Host 'karstsrv.nmsrv.com' is known and matches the ECDSA host key.
debug1: Found key in /home/karst/.ssh/known_hosts:4
debug3: send packet: type 21
debug2: set_newkeys: mode 1
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug3: receive packet: type 21
debug2: set_newkeys: mode 0
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS received
debug2: key: /home/karst/.ssh/id_rsa (0x5583355be270)
debug3: send packet: type 5
debug3: receive packet: type 6
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug3: send packet: type 50
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,keyboard-interactive
debug3: start over, passed a different list publickey,keyboard-interactive
debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/karst/.ssh/id_rsa
debug3: send_pubkey_test
debug3: send packet: type 50
debug2: we sent a publickey packet, wait for reply
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,keyboard-interactive
debug2: we did not send a packet, disable method
debug3: authmethod_lookup keyboard-interactive
debug3: remaining preferred: password
debug3: authmethod_is_enabled keyboard-interactive
debug1: Next authentication method: keyboard-interactive
debug2: userauth_kbdint
debug3: send packet: type 50
debug2: we sent a keyboard-interactive packet, wait for reply
debug3: receive packet: type 60
debug2: input_userauth_info_req
debug2: input_userauth_info_req: num_prompts 1

As far as I can tell it seems that OpenSSH is not able to find my id_rsa file located at ~/.ssh/id_rsa. This file definitely exists and appears to have the proper permissions as evidenced by the output of ls -al:

total 72
drwx------  2 karst karst 4096 Jan 30 12:34 .
drwxr-xr-x 54 karst karst 4096 Jan 30 12:34 ..
-rw-------  1 karst karst  401 Dec 14 11:33 authorized_keys
-rw-------  1 karst karst 1679 Jan 16 14:32 google_compute_engine
-rw-r--r--  1 karst karst  400 Jan 16 14:32 google_compute_engine.pub
-rw-r--r--  1 karst karst  444 Jan 17 12:42 google_compute_known_hosts
-rw-------  1 karst karst 1675 Nov 15 13:51 id_rsa
-rw-r--r--  1 karst karst  400 Nov 15 13:51 id_rsa.pub
-rw-------  1 karst karst 6212 Jan 25 13:26 known_hosts

What is going on here? What does "key_load_public: no such file or directory" mean?

3

You see several times in the debug log that your ssh client did load your id_rsa key:

debug1: identity file /home/karst/.ssh/id_rsa type 1

...

debug2: key: /home/karst/.ssh/id_rsa (0x5583355be270)

and offers it to the server ...

debug1: Offering RSA public key: /home/karst/.ssh/id_rsa

... and there's hope ...

debug1: Authentications that can continue: publickey,keyboard-interactive

... until:

debug3: remaining preferred: password

When the SSH server decided to not accept your key for authentication. Perhaps the destination permissions were not correct, or the key was not loaded to the authorized_keys file, or the SSH daemon is not configured to accept key authentication, etc. You are right to chase down the hosting company with your debug logs, showing that they are not accepting key authentication.

What, exactly, does "key_load_public: no such file or directory" mean?

From https://superuser.com/a/962895/513541:

it talks about the file mentioned below, not above. You have just the regular public keys, but you do not have the SSH certificates for them (presumably because you just don't need them). OpenSSH however will always try to load the associated .pub-cert file for each identity key.

  • Thanks for the confirmation Jeff. I figured it was on their side as everything seemed well on my end. – scubadiver124 Jan 30 '18 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.