0

Somehow (I have no idea how) I broke my ALT + TAB functionality. I'm using Linux Mint (MATE edition), and when I press ALT + TAB instead of switching to another application it very briefly shows the desktop, then returns me back to the application I was on.

I've tried enabling and disabling both the "Application Switcher" and "Static Application Switcher" in the CompizConfig, but neither has any effect. Even if both are disabled, I still get the same "briefly show the desktop then return to the original app" behavior.

This made me think that I somehow had rebound my ALT + TAB keybinding, but when I go to Keyboard Shortcuts it does show "Move between windows, using a popup window" set to ALT + TAB. If I change it (eg. to CTRL + ALT + A) the "show desktop briefly" behavior goes away ... unless I then do CTRL + ALT + A, in which case that behavior returns.

So in summary:

  • I have a keybinding for ALT + TAB to "Move between windows, using a popup window", and this binding appears to trigger the "show desktop briefly" behavior even if I change it to a different binding
  • I previously had "Static Application Switcher" enabled in CompizConfig, but whether I enable it, "Application Switcher", or none of the above, I see the same behavior

Thus, it seems I've somehow actually broken the "Move between windows, using a popup window" functionality, completely independent of Compiz ... and I have no idea how I can restore it.

Does anyone have any suggestions?

1
  • I am having the same issue – BenjB Oct 28 '18 at 18:24
2

I had same issue. Disabling "software compositing window manager" worked for me:

https://makandracards.com/makandra/47066-ubuntu-mate-fixing-alt-+-tab-being-really-slow

0
0

I had a fresh install and ran into this again, but found a new solution.

First, I installed and ran dconf-editor (sudo apt-get install dconf-editor followed by dconf-editor). This let me edit system settings using a friendly GUI (you could also just use the, already installed, command-line `gsettings to do the same thing).

Then I used it to change two settings:

org.mate.marco.global-keybindings.cycle-windows org.mate.marco.global-keybindings.switch-windows

"cycle-windows" is an action which switches immediately the moment you press ALT+TAB, while "switch-windows" uses the pop-up window, causing slowness. On my machine switch-windows was bound to ALT+TAB, while cycle-windows was set to ALT+ESCAPE.

All I had to do was switch those two values, and suddenly I had super-fast ALT+TAB switching! And as an added bonus, cycle-windows limits itself to applications open on the current workspace (only).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.