0

It is impossible to install Zabbix with apt-get install on my Debian 9. I was following instructions on Zabbix page - I choose version 3.4 - Debian 9 - PostgreSQL but also 3.2, 3.0 LTS version or MySQL instead Postgres - no effect. When I try to install Zabbix with command:

apt install zabbix-server-pgsql zabbix-frontend-php php-pgsql zabbix-agent

Then output looks like this (original output in polish - this is my translate):

(...)
incorrect checksum
  Hashes of expected file:
    SHA256: 2cd774 (...)
    MD5Sum: 2636bf (...)
    Filesize: 231550 [weak]
  Hashes of received file:
    SHA256: 9214bd (...)ap
    MD5Sum: e4c0b (...)
    Filesize: 2438 [weak]
last modification reported: Tue, 30 Jan 2018, 17:04
E: Cannot download some files, please try apt-get update or --fix-missing option

Of-course apt-get update or --fix-missing not resolved problem. My sources.list is standard (Polish Debian repositories) but I also tried US or even Australian test servers.

I tried

rm -rf /var/lib/apt/lists/*

and apt-get clean, update, upgrade etc. Nothing helped. Problem is only with zabbix-server-pgsql or zabbix-server-mysql. Other packages installed correctly. The same problem is with 3.2 and 3.0 LTS version.

EDIT

I used following instruction before apt install:

 wget http://repo.zabbix.com/zabbix/3.4/debian/pool/main/z/zabbix-release/zabbix-release_3.4-1+stretch_all.deb
 dpkg -i zabbix-release_3.4-1+stretch_all.deb
 apt update 

Instructions from zabbix.com/download page. Moreover, I tried to install Zabbix on my test Debian 8 on VirtualBox and there is a problem too, but only information is after apt install is -

cannot download (...) libsnmp30 (...) - wrong size

SOLVED - Fortigate firewall blocked libsnmp30 package - even if I want download it from web browser from Debian repositories. I downloaded it by proxy, install package by dpkg and it works.

  • 1
    Which exact instructions did you follow and what commands did you run prior to apt install? – Richlv Jan 30 '18 at 17:48
  • @Richlv I used following instruction before apt install: # wget http://repo.zabbix.com/zabbix/3.4/debian/pool/main/z/zabbix-release/zabbix-release_3.4-1+stretch_all.deb' '# dpkg -i zabbix-release_3.4-1+stretch_all.deb' '# apt update Instructions from zabbix.com/download page. Moreover, I tried to install Zabbix on my test Debian 8 on VirtualBox and there is a problem too, but only information is after apt install is - cannot download (...) libsnmp30 (...) - wrong size – Mateusz Nitka Jan 30 '18 at 18:31
  • Please put that information ↑ in your question. It's important – roaima Feb 4 '18 at 20:05
0

Solved! There was a problem with firewall / router which blocked the libsnmp30 package. I downloaded it manually and installed with dpkg.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.