I have installed ncurses package from source, and now I have


on my filesystem. I have also set up the search pathes so that


(i have eddited the output of echo to replace home path with $HOME)

however, when i ./configure another package i get

checking ncurses.h usability... no
checking ncurses.h presence... no

what's the problem that the system cannot detect curses installation?

  • make sure your two paths you mentioned at the start do not have the inlcude typo on the filesystem. Jul 1, 2012 at 19:37
  • @lynxlynxlynx i fixed the typo in the question, thanks for pointing out Jul 1, 2012 at 19:45
  • I found this guide really helpful for statically compiling tmux 1.9 on fedora 19: pyther.net/2014/03/building-tmux-1-9a-statically
    – djeikyb
    Jun 16, 2014 at 16:52

1 Answer 1


configure scripts produce config.log (in the same folder) files which contain all the details on the tests it ran. They're not particularly easy to read, but open it up and search for "checking ncurses.h usability". Look at what went wrong with the small test program it tried to compile.

My guess is, it doesn't care about $C_INCLUDE_PATH and you'll need to pass it to the build system in a different matter. configure options (eg. --includedir=$HOME/local/include) and $CFLAGS + $CXXFLAGS + $CPPFLAGS (adding -I$HOME/local/include) come to mind.

  • I did ./configure CFLAGS=-I/home/w381833/local/include/ncurses CXXFLAGS=-I/home/w381833/local/include/ncurses and I got configure: WARNING: curses.h: accepted by the compiler, rejected by the preprocessor! configure: WARNING: curses.h: proceeding with the compiler's result. I think i am doing something wrong or that something is missing in here Jul 1, 2012 at 20:07
  • 5
    add CPPFLAGS=-I/home/w381833/local/include/ncurses (for the preprocessor). Jul 1, 2012 at 20:10
  • perfect, worked like charm, thanks @lynxlynxlynx Jul 1, 2012 at 20:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .