2

When I type in the command nmap –Pn –sT -sV –p0-65535 192.168.1.100, my terminal responds:

Starting Nmap 7.60 ( https://nmap.org ) at 2018-01-29 11:24 PST
Failed to resolve "–Pn".
Failed to resolve "–sT".
Failed to resolve "–p0-65535".
Nmap scan report for 192.168.1.100
Host is up (0.0075s latency).
Not shown: 999 closed ports
PORT   STATE    SERVICE VERSION
53/tcp filtered domain

Service detection performed. Please report any incorrect results at https://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 1.73 seconds

I'm confused as to why it is failing to resolve the flags. This used to work on my machines; I have a MacBook and am using bash, as well as Kali Linux. I have tried restarting both machines, and it continually fails to resolve flags regardless of which IP address I attempt to scan.

2

nmap did not recognize those options because they start with a unicode EN DASH (342 200 223, ) instead of a hyphen or regular dash (-). As a result, nmap interprets those "options" as names to resolve.

  • Wow, changing it to normal dashes worked. Although this is embarrassing, your answer helped! Thanks a lot :) – keala Jan 29 '18 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.