I just install a CentOS 7 by DVD iso on my USB as what you'll do to install normal centos (not live-USB) with my laptop with UEFI boot mode and it can be successfully booted on my laptop too.

So as I installed it from UEFI mode it should be able to boot in any computer that is in UEFI mode (in theory) but I can't boot it on other computers. I've entered BIOS and disable secure boot enable CSM but it kept returning the following error:

Failed to open \EFI\BOOT\grubx64.efi - Not Found
Failed to load image \EFI\BOOT\grubx64.efi: Not Found
start_image() returned Not Found

And I don't know how to solve this

And here's the image for configuration in BIOS and also the log it returned when I boot from my USB:

image for config in BIOS and err log

  • Is there no option to boot in legacy mode only? Jan 29, 2018 at 11:10
  • @RamanSailopal For the first image yes there is legacy only but I'm sure that the CentOS 7 is installed under UEFI mode which should be only able to boot under UEFI (right?) Jan 29, 2018 at 11:11

1 Answer 1


I had this issue today while trying to install CentOS on a USB drive. It was resolved by copying the "missing" file from one folder to another on the ESI partition.

I booted into an existing Ubuntu partition... you could do the same with a rescue disk. I ran sudo blkid to get the list of partitions... for me, the EFI partition on the USB drive was /dev/sdc1 . So I mounted it, and copied the file:

mkdir /tmp/sdefi
sudo mount /dev/sdc1 /tmp/sdefi
sudo cp /tmp/sdefi/EFI/centos/grubx64.efi /tmp/sdefi/EFI/BOOT/
sudo umount /tmp/sdefi

After that I was able to boot from USB. If you try it, be sure to substitute the right partition name for /dev/sdc1 in the mount command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.